cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Higginbottom <>
Subject RE: CloudStack with KVM and Open vSwitch
Date Fri, 28 Sep 2012 08:50:03 GMT

This symptom is typically caused by not having your VLANs for your Guest network traffic configured
correctly on your Switches.

Check to ensure the VLAN ranges you are using for your Guest Networks have been applied to
your switch.



-----Original Message-----
From: 汤聿津 []
Sent: 28 September 2012 09:07
Subject: Re: CloudStack with KVM and Open vSwitch

Got another question.
I have 2 hypervisor boxes and have created 2 guest networks and
The first one works perfect.
But the second one is a little weird ... I can ping from the System Router VM to my instance
ONLY IF the guest is running on the same hypervisor box as the SRVM.
I thought the cause (not likely though) might be the guest CIDR settings in the zone, so I
changed the default to and tried again, no luck.
Can anyone help me out?

On Fri, Sep 28, 2012 at 3:54 PM, 汤聿津 <> wrote:
> Is it possible to get rid of this has-to-be-VLAN thing?
> Will it work, for instance, if I replace the cloud0.XXX vlan interface
> with some arbitrary non-vlan tap interface?
> On Fri, Sep 28, 2012 at 3:47 PM, Lerry <> wrote:
>> Hi, kirk
>> Thanks for the reply.
>> That's ... frustrating ...
>> Sent from my iPhone
>> On 2012/09/28, at 14:33, Kirk Kosinski <> wrote:
>>> Hi, Lerry.  In CS 3.0.x, using security groups is only possible in
>>> basic zones.
>>> Best regards,
>>> Kirk
>>> On 09/27/2012 09:35 PM, 汤聿津 wrote:
>>>> Thanks for the reply.
>>>> But after I edit the script at
>>>> /usr/lib64/cloud/agent/scripts/vm/network/vnet/, I am
>>>> now able to create instances with KVM+Open vSwitch.
>>>> Have another question though.
>>>> I remember that guest network can be either isolated with VLAN or
>>>> Security Groups, but I wasn't asked to make such a choice when I
>>>> created my Advanced Zone.
>>>> Am I missing some steps in the installation guide?
>>>> Best regards,
>>>> Lerry
>>>> On Thu, Sep 27, 2012 at 6:10 PM, prasanna <> wrote:
>>>>> On 27 September 2012 13:12, 汤聿津 <> wrote:
>>>>>> Hi all,
>>>>>> I know that CloudStack can work with XenServer in which Open
>>>>>> vSwitch is installed.
>>>>>> Can it work with KVM+OVS as well?
>>>>>> I tried to do so and had no problem until I tried to create some
>>>>>> instances, the error message was like
>>>>>> Failed to create vnet
>>>>>> 1149: Set name-type for VLAN subsystem. Should be visible in
>>>>>> /proc/net/vlan/configERROR:  if_name must be 15 characters or
>>>>>> less.Failed to create vlan 1149 on pif: /sys/class/net/cloud0/bridge:.
>>>>>> <<
>>>>>> Obviously, the underlying network is blamed.
>>>>>> Am I missing something in my configuration I should have paid
>>>>>> attention to, or it just can't be done?
>>>>>> If the answer is the latter one, any one please give me a reason?
>>>>>> Best regards,
>>>>>> Lerry
>>>>> The support is yet to be added and scheduled for the next release.
>>>>> Please up-vote:
>>>>> Thanks

ShapeBlue provides a range of strategic and technical consulting and implementation services
to help IT Service Providers and Enterprises to build a true IaaS compute cloud. ShapeBlue’s
expertise, combined with CloudStack technology, allows IT Service Providers and Enterprises
to deliver true, utility based, IaaS to the customer or end-user.


This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd. If you are not the
intended recipient of this email, you must neither take any action based upon its contents,
nor copy or show it to anyone. Please contact the sender if you believe you have received
this email in error. Shape Blue Ltd is a company incorporated in England & Wales.
View raw message