cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Changman Lee <cm224....@samsung.com>
Subject RE: How to make VM from ISO file ???
Date Wed, 12 Sep 2012 02:33:06 GMT
Management server is used NFS server supporting /export/primary and /export/secondary.

Node1 (cluster 1) and Node2 (cluster 2) use them through nfs. (e.g. In node1, mount -t nfs
manager:/export/primary /primarymount)

If my configuration is wrong, How do I add primary storage in my cluster 1 and cluster 2?


* Infrastructure > Clusters > cluster1

Name : cluster1
ID : xxxxxxxxxxx
Zone : zone1
Pod : pod1
Hypervisor : KVM
Cluster Type : CloudManaged
State : Enabled

Where can I see the primary storage??


> -----Original Message-----
> From: Edison Su [mailto:Edison.su@citrix.com]
> Sent: Wednesday, September 12, 2012 11:13 AM
> To: cloudstack-users@incubator.apache.org
> Subject: RE: How to make VM from ISO file ???
> 
> Did you add primary storage in your clusters from UI?
> 
> > -----Original Message-----
> > From: Changman Lee [mailto:cm224.lee@samsung.com]
> > Sent: Tuesday, September 11, 2012 5:10 PM
> > To: cloudstack-users@incubator.apache.org
> > Subject: RE: How to make VM from ISO file ???
> >
> >
> > This is the /var/log/cloud/management/management-server.log
> >
> > It seems that my problem is storage allocation.
> >
> > My infrastructure information.
> >
> > * Zones
> > Zones : 1
> > Pods : 1
> > Cluster : 2
> > Hosts : 2
> >
> > * Hosts
> > Total Hosts : 2
> > Total CPU : 39.61GHz
> > Total Memory : 7.64 GB
> > Total Storage: 0.00 KB
> >
> > Where is my storage gone ???
> > And after rebooting manager, node1 and node2, Node1/2 does not remount
> > NFS automatically.
> > So I was mounted nfs storage manually.
> >
> >
> > * Management Server
> > $ cat /etc/exports
> > /export *(rw,async,no_root_squash,no_subtree_check)
> >
> > * Node1
> > $ mount
> > 192.168.2.2:/export/secondary on /secondarymount type nfs
> > (rw,addr=192.168.2.2)
> > 192.168.2.2:/export/primary on /primarymount type nfs
> > (rw,addr=192.168.2.2)
> >
> > * Node2
> > $ mount
> > 192.168.2.2:/export/secondary on /secondarymount type nfs
> > (rw,addr=192.168.2.2)
> > 192.168.2.2:/export/primary on /primarymount type nfs
> > (rw,addr=192.168.2.2)
> >
> >
> >
> > 2012-09-12 08:35:17,099 DEBUG [agent.manager.AgentManagerImpl]
> > (AgentManager-Handler-1:null) Ping from 4
> > 2012-09-12 08:35:22,329 DEBUG [cloud.user.AccountManagerImpl]
> > (catalina-exec-17:null) Access granted to Acct[2-admin] to Domain:1/ by
> > DomainChecker
> > 2012-09-12 08:35:32,494 DEBUG [cloud.server.StatsCollector]
> > (StatsCollector-3:null) HostStatsCollector is running...
> > 2012-09-12 08:35:33,104 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (AgentManager-Handler-13:null) Cleanup succeeded. Details null
> > 2012-09-12 08:35:33,104 DEBUG [agent.transport.Request]
> > (StatsCollector-3:null) Seq 5-130942080: Received:  { Ans: , MgmtId:
> > 255102172799379, via: 5, Ver: v1, Flags: 10, { GetHostStatsAnswer } }
> > 2012-09-12 08:35:33,104 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (StatsCollector-3:null) Cleanup succeeded. Details null
> > 2012-09-12 08:35:41,866 DEBUG [cloud.user.AccountManagerImpl]
> > (catalina-exec-2:null) Access granted to Acct[2-admin] to Domain:1/ by
> > DomainChecker
> > 2012-09-12 08:35:45,799 DEBUG
> > [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
> > Zone 1 is ready to launch secondary storage VM
> > 2012-09-12 08:35:45,861 DEBUG
> > [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null) Zone
> > 1 is ready to launch console proxy
> > 2012-09-12 08:35:46,357 DEBUG
> > [network.router.VirtualNetworkApplianceManagerImpl]
> > (RouterStatusMonitor-1:null) Found 0 routers.
> > 2012-09-12 08:35:47,764 DEBUG [cloud.vm.UserVmManagerImpl] (catalina-
> > exec-4:null) Allocating in the DB for vm
> > 2012-09-12 08:35:47,764 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (catalina-exec-4:null) Allocating entries for VM: VM[User|i-2-5-VM]
> > 2012-09-12 08:35:47,769 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (catalina-exec-4:null) Allocating nics for VM[User|i-2-5-VM]
> > 2012-09-12 08:35:47,778 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (catalina-exec-4:null) Allocaing disks for VM[User|i-2-5-VM]
> > 2012-09-12 08:35:47,786 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (catalina-exec-4:null) Allocation completed for VM: VM[User|i-2-5-VM]
> > 2012-09-12 08:35:47,786 DEBUG [cloud.vm.UserVmManagerImpl] (catalina-
> > exec-4:null) Successfully allocated DB entry for VM[User|i-2-5-VM]
> > 2012-09-12 08:35:48,287 DEBUG [cloud.async.AsyncJobManagerImpl]
> > (catalina-exec-4:null) submit async job-23, details: AsyncJobVO {id:23,
> > userId: 2, accountId: 2, sessionKey: null, instanceType: VirtualMachine,
> > instanceId: 5, cmd: com.cloud.api.commands.DeployVMCmd, cmdOriginator:
> > null, cmdInfo: {"id":"5","templateId":"92769d7f-2370-4b60-8f0a-
> > fe538378b026","response":"json","sessionkey":"4CbSVVi04JEftDzlPJpwrEIU8
> > HI\u003d","ctxUserId":"2","hypervisor":"KVM","serviceOfferingId":"78a0e
> > b33-cd55-4d05-94f7-f145ca346c0b","diskOfferingId":"8809a2c9-41d0-4ec9-
> > b6dd-
> > e9d275187c6c","_":"1347406404861","ctxAccountId":"2","ctxStartEventId":
> > "101","zoneId":"e8561b3a-1311-4ddb-ac8d-592dccc218ab"}, cmdVersion: 0,
> > callbackType: 0, callbackAddress: null, status: 0, processStatus: 0,
> > resultCode: 0, result: null, initMsid: 255102172799379, completeMsid:
> > null, lastUpdated: null, lastPolled: null, created: null}
> > 2012-09-12 08:35:48,288 DEBUG [cloud.async.AsyncJobManagerImpl] (Job-
> > Executor-8:job-23) Executing com.cloud.api.commands.DeployVMCmd for
> > job-23
> > 2012-09-12 08:35:48,414 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23) VM state transitted from :Stopped to Starting
> > with event: StartRequestedvm's original host id: null new host id: null
> > host id before state transition: null
> > 2012-09-12 08:35:48,414 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (Job-Executor-8:job-23) Successfully transitioned to start state for
> > VM[User|i-2-5-VM] reservation id = ef9ccb42-5ff6-404f-8a03-de8fd02f447e
> > 2012-09-12 08:35:48,497 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (Job-Executor-8:job-23) Trying to deploy VM, vm has dcId: 1 and podId:
> > null
> > 2012-09-12 08:35:48,497 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > (Job-Executor-8:job-23) Deploy avoids pods: null, clusters: null, hosts:
> > null
> > 2012-09-12 08:35:48,499 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) DeploymentPlanner allocation algorithm: random
> > 2012-09-12 08:35:48,499 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Trying to allocate a host and storage pools from
> > dc:1, pod:null,cluster:null, requested cpu: 500, requested ram:
> > 536870912
> > 2012-09-12 08:35:48,499 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Is ROOT volume READY (pool already allocated)?: No
> > 2012-09-12 08:35:48,499 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Searching all possible resources under this Zone: 1
> > 2012-09-12 08:35:48,501 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Listing clusters in order of aggregate capacity,
> > that have (atleast one host with) enough CPU and RAM capacity under
> > this Zone: 1
> > 2012-09-12 08:35:48,502 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) CPUOverprovisioningFactor considered: 1.0
> > 2012-09-12 08:35:48,511 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Checking resources in Cluster: 3 under Pod: 1
> > 2012-09-12 08:35:48,511 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Calling HostAllocators to find suitable hosts
> > 2012-09-12 08:35:48,511 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Looking for hosts in dc: 1
> > pod:1  cluster:3
> > 2012-09-12 08:35:48,513 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) FirstFitAllocator has 1
> > hosts to check for allocation: [Host[-5-Routing]]
> > 2012-09-12 08:35:48,515 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Found 1 hosts for
> > allocation after prioritization: [Host[-5-Routing]]
> > 2012-09-12 08:35:48,515 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Looking for speed=500Mhz,
> > Ram=512
> > 2012-09-12 08:35:48,516 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23 FirstFitRoutingAllocator) Checking if host: 5
> > has enough capacity for requested CPU: 500 and requested RAM:
> > 536870912 , cpuOverprovisioningFactor: 1.0
> > 2012-09-12 08:35:48,518 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23 FirstFitRoutingAllocator) Hosts's actual total
> > CPU: 12404 and CPU after applying overprovisioning: 12404
> > 2012-09-12 08:35:48,518 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23 FirstFitRoutingAllocator) Free CPU: 12404 ,
> > Requested CPU: 500
> > 2012-09-12 08:35:48,518 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23 FirstFitRoutingAllocator) Free RAM: 4064256000 ,
> > Requested RAM: 536870912
> > 2012-09-12 08:35:48,518 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23 FirstFitRoutingAllocator) Host has enough CPU
> > and RAM available
> > 2012-09-12 08:35:48,518 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23 FirstFitRoutingAllocator) STATS: Can alloc CPU
> > from host: 5, used: 0, reserved: 0, actual total: 12404, total with
> > overprovisioning: 12404; requested
> > cpu:500,alloc_from_last_host?:false ,considerReservedCapacity?: true
> > 2012-09-12 08:35:48,518 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23 FirstFitRoutingAllocator) STATS: Can alloc MEM
> > from host: 5, used: 0, reserved: 0, total: 4064256000; requested mem:
> > 536870912,alloc_from_last_host?:false ,considerReservedCapacity?: true
> > 2012-09-12 08:35:48,518 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Found a suitable host,
> > adding to list: 5
> > 2012-09-12 08:35:48,518 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Host Allocator returning 1
> > suitable hosts
> > 2012-09-12 08:35:48,519 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Checking suitable pools for volume (Id, Type):
> > (8,ROOT)
> > 2012-09-12 08:35:48,519 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) We need to allocate new storagepool for this volume
> > 2012-09-12 08:35:48,519 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Calling StoragePoolAllocators to find suitable pools
> > 2012-09-12 08:35:48,519 DEBUG
> > [storage.allocator.FirstFitStoragePoolAllocator] (Job-Executor-8:job-23)
> > Looking for pools in dc: 1  pod:1  cluster:3
> > 2012-09-12 08:35:48,520 DEBUG
> > [storage.allocator.FirstFitStoragePoolAllocator] (Job-Executor-8:job-23)
> > No storage pools available for allocation, returning
> > 2012-09-12 08:35:48,520 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) No suitable pools found for volume: Vol[8|vm=5|ROOT]
> > under cluster: 3
> > 2012-09-12 08:35:48,520 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) No suitable pools found
> > 2012-09-12 08:35:48,520 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) No suitable storagePools found under this Cluster: 3
> > 2012-09-12 08:35:48,521 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Checking resources in Cluster: 1 under Pod: 1
> > 2012-09-12 08:35:48,521 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Calling HostAllocators to find suitable hosts
> > 2012-09-12 08:35:48,521 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Looking for hosts in dc: 1
> > pod:1  cluster:1
> > 2012-09-12 08:35:48,523 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) FirstFitAllocator has 0
> > hosts to check for allocation: []
> > 2012-09-12 08:35:48,524 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Found 0 hosts for
> > allocation after prioritization: []
> > 2012-09-12 08:35:48,524 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Looking for speed=500Mhz,
> > Ram=512
> > 2012-09-12 08:35:48,524 DEBUG [allocator.impl.FirstFitAllocator] (Job-
> > Executor-8:job-23 FirstFitRoutingAllocator) Host Allocator returning 0
> > suitable hosts
> > 2012-09-12 08:35:48,524 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) No suitable hosts found
> > 2012-09-12 08:35:48,524 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) No suitable hosts found under this Cluster: 1
> > 2012-09-12 08:35:48,524 DEBUG [cloud.deploy.FirstFitPlanner] (Job-
> > Executor-8:job-23) Could not find suitable Deployment Destination for
> > this VM under any clusters, returning.
> > 2012-09-12 08:35:48,687 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23) VM state transitted from :Starting to Stopped
> > with event: OperationFailedvm's original host id: null new host id:
> > null host id before state transition: null
> > 2012-09-12 08:35:48,854 DEBUG [cloud.capacity.CapacityManagerImpl]
> > (Job-Executor-8:job-23) VM state transitted from :Stopped to Error with
> > event: OperationFailedToErrorvm's original host id: null new host id:
> > null host id before state transition: null
> > 2012-09-12 08:35:49,634 INFO  [api.commands.DeployVMCmd] (Job-Executor-
> > 8:job-23) com.cloud.exception.InsufficientServerCapacityException:
> > Unable to create a deployment for VM[User|i-2-5-VM]Scope=interface
> > com.cloud.dc.DataCenter; id=1
> > 2012-09-12 08:35:49,634 WARN  [cloud.api.ApiDispatcher] (Job-Executor-
> > 8:job-23) class com.cloud.api.ServerApiException : Unable to create a
> > deployment for VM[User|i-2-5-VM]
> > 2012-09-12 08:35:49,634 DEBUG [cloud.async.AsyncJobManagerImpl] (Job-
> > Executor-8:job-23) Complete async job-23, jobStatus: 2, resultCode: 530,
> > result: com.cloud.api.response.ExceptionResponse@4c307d36
> > 2012-09-12 08:35:53,344 DEBUG [cloud.async.AsyncJobManagerImpl]
> > (catalina-exec-22:null) Async job-23 completed
> > 2012-09-12 08:35:54,536 DEBUG [agent.manager.AgentManagerImpl]
> > (AgentManager-Handler-3:null) Ping from 5
> >
> >
> >
> >
> > > -----Original Message-----
> > > From: Edison Su [mailto:Edison.su@citrix.com]
> > > Sent: Tuesday, September 11, 2012 3:51 PM
> > > To: cloudstack-users@incubator.apache.org
> > > Cc: cloudstack-users@incubator.apache.org
> > > Subject: Re: How to make VM from ISO file ???
> > >
> > > Can you take a look at management server log?
> > >
> > > Sent from my iPhone
> > >
> > > On Sep 10, 2012, at 9:32 PM, "Changman Lee" <cm224.lee@samsung.com>
> > wrote:
> > >
> > > > Due to folks, I am here.
> > > >
> > > > Add Instance
> > > >
> > > > 1. Setup -> ISO
> > > > 2. Select Template / My ISOs -> ubuntu-10.04-desktop-amd64.iso
> > > > 3. Compute offering -> Medium Instance
> > > > 4. Data Disk offering -> Medium
> > > > 5. Network -> Nothing
> > > > 6. Review
> > > >
> > > > Then, Launc VM
> > > > * Details
> > > >
> > > > Internal name : i-2-3-vm
> > > > State : Error
> > > > Hypervisor : KVM
> > > > Group : NULL
> > > > Host : NULL
> > > >
> > > >
> > > > * NIC
> > > > IP Address : NULL
> > > >
> > > >
> > > > Where am I? Any clue???
> > > >
> > > > Regards.
> > > >
> > > >
> > > >> -----Original Message-----
> > > >> From: Changman Lee [mailto:cm224.lee@samsung.com]
> > > >> Sent: Tuesday, September 11, 2012 1:20 PM
> > > >> To: cloudstack-users@incubator.apache.org
> > > >> Subject: RE: How to make VM from ISO file ???
> > > >>
> > > >> Thanks folks.
> > > >>
> > > >> I found following.
> > > >>
> > >
> > http://docs.cloudstack.org/Knowledge_Base/Templates%2F%2FISOs_upload_an
> > d_C
> > > >> on
> > > >> sole_Proxy_issues
> > > >>
> > > >> I'm downloading an ISO file after changed Global setting.
> > > >>
> > > >> Regards.
> > > >>
> > > >>
> > > >>> -----Original Message-----
> > > >>> From: Edison Su [mailto:Edison.su@citrix.com]
> > > >>> Sent: Tuesday, September 11, 2012 1:00 PM
> > > >>> To: cloudstack-users@incubator.apache.org
> > > >>> Subject: RE: How to make VM from ISO file ???
> > > >>>
> > > >>> If you are in the corporate network, and need proxy to access
> > public
> > > >>> network, then downloading template/iso doesn't work. This is a
> > known
> > > >> issue.
> > > >>>
> > > >>>> -----Original Message-----
> > > >>>> From: Changman Lee [mailto:cm224.lee@samsung.com]
> > > >>>> Sent: Monday, September 10, 2012 8:50 PM
> > > >>>> To: cloudstack-users@incubator.apache.org
> > > >>>> Subject: RE: How to make VM from ISO file ???
> > > >>>>
> > > >>>> Thanks a lot Caleb Call.
> > > >>>>
> > > >>>> I added an ISO file with your advice. But I've encountered
> > another
> > > >>>> problem.
> > > >>>> It seems that my network setting has a problem. I'm using
proxy.
> > > >>>>
> > > >>>>
> > > >>>> Details.
> > > >>>> Zone name : zone1
> > > >>>> Zond ID: ~~~~
> > > >>>> Ready: No
> > > >>>> Status: Connection refused
> > > >>>>
> > > >>>> Maybe, do you know that manager accesses connection port to
> > download
> > > >>>> ISO
> > > >>>> file
> > > >>>> or log filename (/var/log/cloud/~~~~) to debug???
> > > >>>>
> > > >>>> Authorized
> > > >>>>     PC      -- eth0 (proxy is set.)
> > > >>>>              `- eth1 (192.168.2.1) <-------> Manager
> > (192.168.2.2)
> > > >>>>                                                  |--> Node1
> > > >>>> (192.168.2.10)
> > > >>>>                                                  `--> Node2
> > > >>>> (192.168.2.11)
> > > >>>>
> > > >>>> Regards.
> > > >>>>
> > > >>>>
> > > >>>>> -----Original Message-----
> > > >>>>> From: Caleb Call [mailto:calebcall@me.com]
> > > >>>>> Sent: Tuesday, September 11, 2012 11:13 AM
> > > >>>>> To: cloudstack-users@incubator.apache.org
> > > >>>>> Subject: Re: How to make VM from ISO file ???
> > > >>>>>
> > > >>>>> Sorry, that should be Templates tab on the LEFT side.
> > > >>>>>
> > > >>>>> On Sep 10, 2012, at 8:12 PM, Caleb Call <calebcall@me.com>
> > wrote:
> > > >>>>>
> > > >>>>>> Go to the Templates tab on the right side, drop down
the menu
> > in
> > > >>>> the top
> > > >>>>> left, choose ISO.  Then on the top right, choose Add ISO.
 Once
> > it's
> > > >>>>> downloaded and installed, the State will be Ready, you
will
> > find it
> > > >>>> in the
> > > >>>>> list of available ISOs.
> > > >>>>>>
> > > >>>>>>
> > > >>>>>> On Sep 10, 2012, at 8:04 PM, Changman Lee
> > <cm224.lee@samsung.com>
> > > >>>> wrote:
> > > >>>>>>
> > > >>>>>>> Thanks folks.
> > > >>>>>>>
> > > >>>>>>> Okay, I'll try to create template with ISO first.
:)
> > > >>>>>>>
> > > >>>>>>> Next, question.
> > > >>>>>>> 1. Add Instance.
> > > >>>>>>> 2. Select a zone. -> Zone1
> > > >>>>>>> 3. Select ISO or template. -> ISO
> > > >>>>>>> 4. My ISOs -> I can't look at any ISO files
> > > >>>>>>>
> > > >>>>>>> Where should I upload an ISO file?
> > > >>>>>>> Where does the CloudStack find an ISO file from?
> > > >>>>>>>
> > > >>>>>>> Regards.
> > > >>>>>>>
> > > >>>>>>>> -----Original Message-----
> > > >>>>>>>> From: Marcos Ortiz [mailto:marcos_ortiz@anadat.es]
> > > >>>>>>>> Sent: Monday, September 10, 2012 8:40 PM
> > > >>>>>>>> To: cloudstack-users@incubator.apache.org
> > > >>>>>>>> Subject: RE: How to make VM from ISO file
???
> > > >>>>>>>>
> > > >>>>>>>> Hi,
> > > >>>>>>>>
> > > >>>>>>>> I always créate the first template from ISO,
you only need
> > to
> > > >>>> upload
> > > >>>>> to
> > > >>>>>>>> webserver, and upload to UI (the secondary
storage VM needs
> > to
> > > >>>> works
> > > >>>>> fine)
> > > >>>>>>>> once it´s upload and appear correctly in
iso tabs, you can
> > use
> > > >> it,
> > > >>>>>>>>
> > > >>>>>>>> It´s important to mark the iso as bootable
while uploading,
> > also
> > > >>>> you
> > > >>>>> need
> > > >>>>>>>> to mark the featured check)
> > > >>>>>>>>
> > > >>>>>>>> Regards
> > > >>>>>>>>
> > > >>>>>>>> Marcos Ortiz
> > > >>>>>>>>
> > > >>>>>>>>
> > > >>>>>>>> -----Mensaje original-----
> > > >>>>>>>> De: claude bariot [mailto:clobariot@gmail.com]
> > > >>>>>>>> Enviado el: lunes, 10 de septiembre de 2012
13:38
> > > >>>>>>>> Para: cloudstack-users@incubator.apache.org
> > > >>>>>>>> Asunto: Re: How to make VM from ISO file ???
> > > >>>>>>>>
> > > >>>>>>>> I'm not sure that this methode run correctely
in CS. Because,
> > I
> > > >>>> never
> > > >>>>> make
> > > >>>>>>>> it successfuly.
> > > >>>>>>>>
> > > >>>>>>>> Bat, for, me, the way for creating a nice
instance is to use
> > > >>>> template.
> > > >>>>>>>> - create your VM from xenserve or ESX before,
and install
> > > >>>> xentools or
> > > >>>>>>>> vmtools into your new Vm.
> > > >>>>>>>> - convert your VM to template,  then, upload
it to your web
> > > >>>> server.
> > > >>>>>>>> - Fron VS UI, in the template tab, create
a new template ...
> > > >>>>>>>>
> > > >>>>>>>> I think, this is the best way.
> > > >>>>>>>>
> > > >>>>>>>> regards
> > > >>>>>>>>
> > > >>>>>>>>
> > > >>>>>>>> On 10 September 2012 12:34, Nitin Mehta
> > <Nitin.Mehta@citrix.com>
> > > >>>> wrote:
> > > >>>>>>>>
> > > >>>>>>>>> More importantly does it show as Ready
in the Templates/ISO
> > > >> tab ?
> > > >>>>>>>>>
> > > >>>>>>>>> -----Original Message-----
> > > >>>>>>>>> From: Marcos Ortiz [mailto:marcos_ortiz@anadat.es]
> > > >>>>>>>>> Sent: Monday, September 10, 2012 3:57
PM
> > > >>>>>>>>> To: cloudstack-users@incubator.apache.org
> > > >>>>>>>>> Subject: RE: How to make VM from ISO file
???
> > > >>>>>>>>>
> > > >>>>>>>>> Hello,
> > > >>>>>>>>>
> > > >>>>>>>>> Dou you upload the ISO file prior to deploy
intance?
> > > >>>>>>>>>
> > > >>>>>>>>> Regards
> > > >>>>>>>>>
> > > >>>>>>>>> Marcos Ortiz
> > > >>>>>>>>>
> > > >>>>>>>>>
> > > >>>>>>>>> -----Mensaje original-----
> > > >>>>>>>>> De: Changman Lee [mailto:cm224.lee@samsung.com]
Enviado el:
> > > >>>> lunes, 10
> > > >>>>>>>>> de septiembre de 2012 11:40
> > > >>>>>>>>> Para: cloudstack-users@incubator.apache.org
> > > >>>>>>>>> Asunto: How to make VM from ISO file ???
> > > >>>>>>>>>
> > > >>>>>>>>> Hello.
> > > >>>>>>>>>
> > > >>>>>>>>> Let me know where ISO file is put into,
please.
> > > >>>>>>>>>
> > > >>>>>>>>> I tried to make VM instance through UI,
but I was not able
> > to
> > > >>>> find My
> > > >>>>>>>> ISOs.
> > > >>>>>>>>>
> > > >>>>>>>>> I'm using KVM and I want to make template
using Ubuntu-
> > 12.04.
> > > >>>>>>>>>
> > > >>>>>>>>>
> > > >>>>>>>>> Thanks.
> > > >>>>>>>>>
> > > >>>>>>>>>
> > > >>>>>>>>>
> > > >>>>>>>>>
> > > >>>>>>>
> > > >>>>>>>
> > > >>>>>>
> > > >



Mime
View raw message