cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olga Smola <olya.sm...@gmail.com>
Subject CloudStack development environment
Date Tue, 07 Aug 2012 08:20:04 GMT
Hi,

Last weeks I had no activities as a committer, because I have a problem
with development environment.
When I started working on CloudStack I had remote deployed CloudStack that
used real resources and it wasn't deployed by myself. I've got environment
ready to use. On company I worked on we were waiting for the cloud
computing project. CloudStack was a really good example to aware with cloud
computing platform, so it was deployed as an example. Few weeks later
project was declined. Despite the fact that the project was canceled I
decided to work on Cloud Stack in my free time because it is interesting to
me. Some time I had access to the remote CloudStack, but now I have no
access to it. First at all I tried to setup environment following the steps
from
http://wiki.cloudstack.org/display/dev/Setting+up+Cloudstack+dev+environment+on+Windows.
But I couldn't add host. Then I tried to use DevCloud from
http://wiki.cloudstack.org/display/COMM/DevCloud. And it was success when I
use DevCloud image without any updates. But to fix something from VPC for
example it was needed to use source from master branch so that I followed
steps from DevCloud manual step 8 ("As a developer, you may want to push
your modified code into DevCloud, and test..."). Then I've permanently
stuckbecause after redeploying I can't create host any more. After
rdelopydb I
have no test data and can't create a host. Without rdeploydb CS isn't
working because as I see db structure on the DevCloud image and from master
branch are different. Also I have comments here
http://wiki.cloudstack.org/display/COMM/DevCloud#comment-thread-11829594.

For me as for UI developer and windows user it's very difficult to setup
CloudStack dev environment, because I'm not skilled in things like
deploying.
I would like to help with bug fixing and other UI things but I can't.

Anybody could help to me?

Best regards,
Olga

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message