cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olga Smola <olya.sm...@gmail.com>
Subject Re: CloudStack development environment
Date Tue, 07 Aug 2012 12:00:28 GMT
Pranav,

thank you for feedback, could you please take a look one more.

Steps I follow:
------ download and Install VirtualBox,
------ download DevCloud image from
http://download.cloud.com/templates/devcloud/DevCloud.ova,
------ import DevCloud image into VB,
------ checkout CloudStack code from Apache git repo into my machine,
------ execute commands "ant clean-all build-all", "ant rdeploy
-Drhost=172.168.56.1 -Dport=2222",  "ant rdeploydb
-Drhost=172.168.56.1 -Dport=2222",  "ant rdebug -Drhost=172.168.56.1
-Dport=2222" ---- all seems success
------ on browser http://192.168.56.1:8080/client/, login as
admin/password, continue with basic installation, use exactly the same
data for creating Zone, pod, cluster, etc that here
http://wiki.cloudstack.org/display/comm/DevCloud - step8/f(Access
CloudStack web UI: http://ip-address-of-your-machine:8080/client,
create a new zone, add pod/cluster/host etc). Following install guide
after add host I should add Primary storage (there is no that step on
the Devcloud manual), so I set similar to the Secondary storage
(path:/opt/storage/primary, server: 10.0.2.15), I don't know if it
makes a sense. On the latest step I click "Launch" button, starts
building cloud, when Adding host it shows an error
http://prntscr.com/ddfba. When I go Back to fix host I see
http://prntscr.com/ddfbr. So I can't add host.


"Could you please attach the logs which highlight the exception thrown
when you try to add a host ? I noticed in the file you attached on the
wiki ,  that you are getting this exception..."
------ here is management-server.log from
/var/log/cloud/management/management-server.log :
http://www.4shared.com/file/rKid6Z4L/management-server.html
------ and vmops.log from /opt/cloudstack/incu*/vmops.log :
http://www.4shared.com/file/57jUJGdW/vmops.html

"Could you also mention the details of the dev-environment , you are
trying to set up ?"
------ I use DevCloud

 Attaching more relevant logs would be even more helpful.
------ which logs can be helpful?

Thanks,
Olga


On Tue, Aug 7, 2012 at 1:46 PM, Pranav Saxena <pranav.saxena@citrix.com> wrote:
>
> Hi Olga,
>
>
>
> Could you please attach the logs which highlight the exception thrown when you try to
add a host ? I noticed in the file you attached on the wiki ,  that you are getting this exception
–
>
>
>
> “Unable to ping management server at 10.0.2.15:9090 due to ConnectException”
>
>
>
> Could you also mention the details of the dev-environment , you are trying to set up
? Attaching more relevant logs would be even more helpful. Also you could have a look at the
following links which deal with a workaround for similar exception –
>
>
>
> http://www.cloudstack.org/forum/9-templates-and-isos/11174-unable-to-create-instance.html
>
> http://bugs.cloudstack.org/browse/CS-15136
>
>
>
> Regards,
>
> Pranav
>
>
>
>
>
> From: Olga Smola [mailto:olya.smola@gmail.com]
> Sent: Tuesday, August 07, 2012 4:07 PM
> To: Pranav Saxena
> Cc: cloudstack-users@incubator.apache.org; cloudstack-dev@incubator.apache.org; Brian
Federle; Sonny Chhen
> Subject: Re: CloudStack development environment
>
>
>
> Hi Pranav,
>
> I don't think so that I have a problem with properties file settings or mysql connection.
Also I have access to db, checked. The problem with DevCloud is that after rdeploying I can't
create a host, so I can't add an instance, etc.
>
> On Tue, Aug 7, 2012 at 12:57 PM, Pranav Saxena <pranav.saxena@citrix.com> wrote:
>
> Hi Olga ,
>
> I  read  your comments on the Cloudstack wiki and I realized that you didn't have the
replace .properties file in your override directory. When you manually create that , you got
to set the DBROOTPW as well.
>
> DBUSER=cloud
> DBPW=cloud
> DBROOTPW=cloud
> MSLOG=vmops.log
> APISERVERLOG=api.log
> DBHOST=localhost
> AGENTLOGDIR=logs
> AGENTLOG=logs/agent.log
> MSMNTDIR=/mnt
> COMPONENTS-SPEC=components-premium.xml
> AWSAPILOG=awsapi.log
> REMOTEHOST=localhost
>
>
> Regarding the JDBC exception which you are getting , the problem could be that  the host
name for the database server (defaulting to localhost) was resolving to IPv6 . For this ,
you might want to check  that mysqld is running and you can connect to it. Also check what
is in /etc/cloud/management/db.properties and verify it has the right IP and credentials for
the database server.
>
> I know you don't have to deploy the db when making CSS /JS changes  but prior to that
you should have the working set up with db connectivity and the mysqld running. Let me know
in case you have any problems. We'll try to resolve your problem at the earliest.
>
>
> Thanks,
> Pranav
>
>
> -----Original Message-----
> From: Olga Smola [mailto:olya.smola@gmail.com]
> Sent: Tuesday, August 07, 2012 1:50 PM
> To: cloudstack-dev@incubator.apache.org; cloudstack-users@incubator.apache.org
> Subject: CloudStack development environment
>
> Hi,
>
> Last weeks I had no activities as a committer, because I have a problem with development
environment.
> When I started working on CloudStack I had remote deployed CloudStack that used real
resources and it wasn't deployed by myself. I've got environment ready to use. On company
I worked on we were waiting for the cloud computing project. CloudStack was a really good
example to aware with cloud computing platform, so it was deployed as an example. Few weeks
later project was declined. Despite the fact that the project was canceled I decided to work
on Cloud Stack in my free time because it is interesting to me. Some time I had access to
the remote CloudStack, but now I have no access to it. First at all I tried to setup environment
following the steps from http://wiki.cloudstack.org/display/dev/Setting+up+Cloudstack+dev+environment+on+Windows.
>
> But I couldn't add host. Then I tried to use DevCloud from http://wiki.cloudstack.org/display/COMM/DevCloud.
And it was success when I use DevCloud image without any updates. But to fix something from
VPC for example it was needed to use source from master branch so that I followed steps from
DevCloud manual step 8 ("As a developer, you may want to push your modified code into DevCloud,
and test..."). Then I've permanently stuckbecause after redeploying I can't create host any
more. After rdelopydb I have no test data and can't create a host. Without rdeploydb CS isn't
working because as I see db structure on the DevCloud image and from master branch are different.
Also I have comments here http://wiki.cloudstack.org/display/COMM/DevCloud#comment-thread-11829594.
>
>
> For me as for UI developer and windows user it's very difficult to setup CloudStack dev
environment, because I'm not skilled in things like deploying.
> I would like to help with bug fixing and other UI things but I can't.
>
> Anybody could help to me?
>
> Best regards,
> Olga
>
>

Mime
View raw message