cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nik Martin <nik.mar...@nfinausa.com>
Subject Re: Can't create template from snapshot
Date Thu, 23 Aug 2012 19:34:49 GMT
On 08/23/2012 11:00 AM, Nitin Mehta wrote:
> Nik - Can you please log in to the hypervisor and see in the logs under /var/log/SMlog
if there is any failure logged there for this operation ? Search for create_privatetemplate_from_snapshot
there.
>
I tailed the SMlog while I was trying to craete a template and nothing 
changed. I also tailed /var/log/messages, and nothing changed there either.

> 34a0115b-466a-492a-b4f4-d4a0db5dc55b which you are wondering about is nothing but a random
UUID for mounting the snapshots directory from sec. storage (on which this snapshot is physically
present). This UUID directory gets deleted as part of the cleanup once the operations is done
and the snapshot directory is unmounted.
> What you need to verify is whether the snapshot is present on sec. storage under the
directory snaphots/account_id/volume_id_of_snapshot/  on sec. storage or if you can find any
evidence of snapshot deleting in the MS logs bcz that seems to be the issue here.
>
Ok, here's what I see.  To get in sync, I deleted all snapshots on this 
VM, and confirmed that the snapshots were deleted from secondary 
storage.  I then created a new snapshot.  Here is the record in the 
snapshots table:
+----+----------------+------------+-----------+-----------+------------------+-----------+--------------------------------------+--------------------------------
| id | data_center_id | account_id | domain_id | volume_id | 
disk_offering_id | status    | path                                 | 
name
+----+----------------+------------+-----------+-----------+------------------+-----------+--------------------------------------+--------------------------------
|  3 |              1 |          2 |         1 |       104 | 
    10 | BackedUp | a0f74cf2-a8c0-40aa-9452-61b110e8b4a8 | 
Android_ROOT-104_20120823192357
+----+----------------+------------+-----------+-----------+------------------+-----------+--------------------------------------+--------------------------------

Cloudstack reports this in the UI:

Name	Android_ROOT-104_20120823192357
ID	005c0d8b-8733-45cb-8ad3-61c25e9eaf01

On the disk on secondary storage, I have:
/export/secondary/snapshots/2/104/42cfab12-e7c6-1418-5050-21cb77c0cc45/

-rw-r--r--. 1 root root 1437274624 Aug 23 14:27 
f4d8a467-c37e-4f4d-a3a3-cf24365f0c36.vhd

So, the snapshot is being created.

> Thanks,
> -Nitin
>
> -----Original Message-----
> From: Nik Martin [mailto:nik.martin@nfinausa.com]
> Sent: Thursday, August 23, 2012 9:05 PM
> To: cloudstack-users@incubator.apache.org
> Subject: Can't create template from snapshot
>
> I recently added a new zone to my CS Acton cloud, using Xenserver 6.02 HVs. My secondary
storage is NFS on Centos 6.  I can upload ISOs, CS downloaed the system template fine, and
I can create VMs, and make snapshots from Volumes.  When I pick a snapshit and try to create
a template, I get:
>
> 2012-08-23 10:09:39,992 WARN  [cloud.vm.VirtualMachineManagerImpl]
> (Job-Executor-29:job-44) Cleanup failed due to Creating template from snapshot 6ec231ac-9468-454c-ab60-5c46c4463799
failed due to
> com.cloud.utils.exception.CloudRuntimeException:
> create_privatetemplate_from_snapshot failed due to failed to query /var/run/cloud_mount/34a0115b-466a-492a-b4f4-d4a0db5dc55b/6ec231ac-9468-454c-ab60-5c46c4463799.vhd
>
> If I log into the HV the VM is running on, and look at /var/run/cloud_mount/, there are
hundreds of directories, but 34a0115b-466a-492a-b4f4-d4a0db5dc55b is not one of them. Is someting
out of sync?
>
> --
> Regards,
>
> Nik
>


-- 
Regards,

Nik



Mime
View raw message