cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mice Xia" <mice_...@tcloudcomputing.com>
Subject RE: A bug about assign VLAN ID to storage network?
Date Thu, 16 Aug 2012 04:23:01 GMT
Kevin,

Sure, actually I committed a fix in 29459549ba883c9dd15d553da71681d2875501d2
Should I file it in the old tracker or just put on hold until the new one is available?

Regards
Mice

-----Original Message-----
From: Kevin Kluge [mailto:Kevin.Kluge@citrix.com] 
Sent: Thursday, August 16, 2012 11:30 AM
To: cloudstack-users@incubator.apache.org
Subject: RE: A bug about assign VLAN ID to storage network?

Mice/Bill, can one of you please make sure to file a bug?  Thanks.

-kevin

> -----Original Message-----
> From: Mice Xia [mailto:mice_xia@tcloudcomputing.com]
> Sent: Monday, August 13, 2012 10:53 PM
> To: cloudstack-users@incubator.apache.org
> Subject: RE: A bug about assign VLAN ID to storage network?
> 
> Yes, this is a bug in zoneWizard, VLAN is failed to save into DB when you add
> it from zoneWizard.
> As William mentioned, you can get around it by adding it on infrastructure
> page.
> 
> Regards
> Mice
> 
> -----Original Message-----
> From: William Clark [mailto:majorgearhead@gmail.com]
> Sent: Tuesday, August 14, 2012 1:08 AM
> To: cloudstack-users@incubator.apache.org
> Cc: <cloudstack-users@incubator.apache.org>
> Subject: Re: A bug about assign VLAN ID to storage network?
> 
> I found the same bug. Here is how I got past it.
> - Take the zone offline (you may need to take pod etc offline as well)
> - stop your system vm's
> - go into you storage network and delete what is there and then re-add with
> the proper vlan.
> - start everything back up
> 
> The trick here is to bring the system vm's down into a state they won't restart
> on their own. If they are running, deleting the storage network info will not
> stick, ie you delete it, move to another config window and then back it will
> magically come back. If the system vm's are truly down the storage network
> line will not come back on it's own and you can add the proper one back.
> 
> Good Luck
> 
> Bill Clark
> 
> On Aug 13, 2012, at 9:25 AM, 曹伟 <caow@travelsky.com> wrote:
> 
> > When I create a advanced zone in CS 3.0.2, I configure storage network
> > IP range, gateway, netmask and VLAN ID, then I assign storage network
> > to a specific physical network interface with trunk connection.
> >
> > But when the zone create completely, I fund that the storage network
> > didn't be assigned the VLAN ID, and it can't go through the trunk interface.
> >
> > I try it on VMWare,XenServer and KVM, the issue will arise on all the
> > platforms!
> >
> >
> >
> > Is it a bug and how to fix it?
> >
> >
> >
Mime
View raw message