cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alena Prokharchyk <Alena.Prokharc...@citrix.com>
Subject Re: Problem: Unable to create a deployment for VM[User|i-2-8-VM]
Date Mon, 16 Jul 2012 23:55:19 GMT
The log states that the host doesn't exist:

com.cloud.exception.AgentUnavailableException: Resource [Host:1] is
unreachable: Host 1: Can't find the host



Can you check the database for host id=1? Make sure its not removed.


On 7/16/12 4:45 PM, "Evan Miller" <Evan.Miller@citrix.com> wrote:

>From CSMS GUI, the State is Up for the host, xenserver1-cs.
>
>Regards,
>Evan
>
>
>-----Original Message-----
>From: Alena Prokharchyk [mailto:Alena.Prokharchyk@citrix.com]
>Sent: Monday, July 16, 2012 4:45 PM
>To: cloudstack-users@incubator.apache.org
>Subject: Re: Problem: Unable to create a deployment for VM[User|i-2-8-VM]
>
>Looks like the Xen host your Virtual Router r-4-VM is running on, is in
>not in UP state. Can you please confirm. If this is the case, then the
>failure is expected. The Xen host should be in UP state.
>
>
>On 7/16/12 4:16 PM, "Evan Miller" <Evan.Miller@citrix.com> wrote:
>
>>Running CloudStack Management Server:
>>  v3.0.2.1
>>On:
>>  [root@cumulus management]# uname -a
>>  Linux cumulus.eng.citrite.net 2.6.32-220.el6.x86_64 #1 SMP Tue Dec 6
>>19:48:22 GMT 2011 x86_64 x86_64 x86_64 GNU/Linux
>>  [root@cumulus management]#
>>Hypervisor :
>>  XenServer v6.02
>> 
>>Hi:
>> 
>>Can¹t add VM instance.
>>Getting this error message from the GUI:
>>  Unable to create a deployment for VM[User|i-2-8-VM]
>> 
>>In the attached log file, there are a few ³apparent² issues when trying
>>to create the instance :
>> 
>>1)
>>2012-07-16 15:56:19,928 DEBUG
>>[network.router.VirtualNetworkApplianceManagerImpl]
>>(Job-Executor-3:job-33) Applying dhcp entry in network
>>Ntwk[204|Guest|5]
>>2012-07-16 15:56:19,943 WARN
>>[network.router.VirtualNetworkApplianceManagerImpl]
>>(Job-Executor-3:job-33) Unable to apply dhcp entry on disconnected
>>router r-4-VM
>>com.cloud.exception.AgentUnavailableException: Resource [Host:1] is
>>unreachable: Host 1: Can't find the host
>> 
>>This one occurred at the beginning of the async job. Not sure if it is
>>an error or not.
>> 
>>2)
>>2012-07-16 15:56:20,521 DEBUG [cloud.capacity.CapacityManagerImpl]
>>(Job-Executor-3:job-33) VM state transitted from :Stopped to Error with
>>event: OperationFailedToErrorvm's original host id: null new host id:
>>null host id before state transition:
>> null
>>2012-07-16 15:56:21,192 INFO  [api.commands.DeployVMCmd]
>>(Job-Executor-3:job-33)
>>com.cloud.exception.InsufficientServerCapacityException: Unable to
>>create a deployment for VM[User|i-2-8-VM]Scope=interface
>>com.cloud.dc.DataCenter; id=1
>>2012-07-16 15:56:21,192 WARN  [cloud.api.ApiDispatcher]
>>(Job-Executor-3:job-33) class com.cloud.api.ServerApiException : Unable
>>to create a deployment for VM[User|i-2-8-VM]
>> 
>>That one doesn¹t look good.
>> 
>>3)
>>2012-07-16 15:56:30,263 DEBUG [cloud.server.StatsCollector]
>>(StatsCollector-1:null) There is no secondary storage VM for secondary
>>storage host nfs://cumulus.eng.citrite.net/home/export/secondary
>>
>>
>>From CloudStack GUI, secondary storage is defined and enabled.
>> 
>>What¹s important, which needs to be fixed and how to fix?
>> 
>>Thanks.
>> 
>>Regards,
>> 
>>Evan Miller
>> 
>>Citrix Systems. Inc.
>>Desktop and Cloud Engineering Infrastructure
>>4988 Great America Parkway
>>Santa Clara, CA 95054
>> 
>>
>>
>
>
>


Mime
View raw message