cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edison Su <Edison...@citrix.com>
Subject RE: Vsphere host into existing XenServer pod
Date Tue, 24 Jul 2012 20:14:32 GMT
1. Need to create a VMware data store
2. Go to UI->Infrastructure -> primary storage -> add primary storage -> choose
the vmware cluster, add the data store from the UI.

> -----Original Message-----
> From: claude bariot [mailto:clobariot@gmail.com]
> Sent: Tuesday, July 24, 2012 1:36 AM
> To: cloudstack-users@incubator.apache.org
> Subject: Re: Vsphere host into existing XenServer pod
>
> How can I do it from UI ?
>
> On 23 July 2012 22:50, Edison Su <Edison.su@citrix.com> wrote:
>
> > From the log, seems you haven't add a primary storage into your
> vmware
> > cluster.
> >
> > > -----Original Message-----
> > > From: claude bariot [mailto:clobariot@gmail.com]
> > > Sent: Monday, July 23, 2012 1:30 AM
> > > To: cloudstack-users@incubator.apache.org
> > > Subject: Re: Vsphere host into existing XenServer pod
> > >
> > >
> =======================================================================
> > >
> > > The zone you selected does not have any choices for network
> selection.
> > >
> > > Please proceed to the next step.
> > >
> > >
> =======================================================================
> > > ===
> > >
> > >
> > >
> > > cloud-cms1:~# tail -1000f /var/log/cloud/management/management-
> > > server.log |
> > > grep -i job-29
> > > 2012-07-11 11:12:41,703 DEBUG [cloud.async.AsyncJobManagerImpl]
> > > (catalina-exec-25:null) submit async job-29, details: AsyncJobVO
> {id:29,
> > > userId: 2, accountId: 2, sessionKey: null, instanceType:
> VirtualMachine,
> > > instanceId: 7, cmd: com.cloud.api.commands.DeployVMCmd,
> cmdOriginator:
> > > null, cmdInfo:
> > >
> {"sessionkey":"/vox7C+U+DO69K3tA4j+gGKvKp8\u003d","ctxUserId":"2","serv
> > > iceOfferingId":"547b04e6-4824-4a12-a25b-
> > > 818cfab8307b","zoneId":"9cb3c81d-b50e-42a8-a873-
> > > e3f62a1001bb","response":"json","templateId":"c0d310e3-fa55-4c75-
> a191-
> > > 9e85ee91a59d","id":"7","hypervisor":"VMware","name":"vs-deb-
> > > vm1","_":"1341998013466","ctxAccountId":"2","group":"vsphe-
> > > vm","ctxStartEventId":"113","displayname":"vs-deb-vm1"},
> > > cmdVersion: 0, callbackType: 0, callbackAddress: null, status: 0,
> > > processStatus: 0, resultCode: 0, result: null, initMsid:
> > > 255332404581359,
> > > completeMsid: null, lastUpdated: null, lastPolled: null, created:
> null}
> > > 2012-07-11 11:12:41,705 DEBUG [cloud.async.AsyncJobManagerImpl]
> > > (Job-Executor-5:job-29) Executing
> com.cloud.api.commands.DeployVMCmd
> > > for
> > > job-29
> > > 2012-07-11 11:12:41,838 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29) VM state transitted from :Stopped to
> Starting
> > > with
> > > event: StartRequestedvm's original host id: null new host id: null
> host
> > > id
> > > before state transition: null
> > > 2012-07-11 11:12:41,838 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > > (Job-Executor-5:job-29) Successfully transitioned to start state
> for
> > > VM[User|i-2-7-VM] reservation id = 2f8e4d22-b109-4ac2-8bb6-
> b488c52f71ae
> > > 2012-07-11 11:12:41,937 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > > (Job-Executor-5:job-29) Trying to deploy VM, vm has dcId: 1 and
> podId:
> > > null
> > > 2012-07-11 11:12:41,938 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> > > (Job-Executor-5:job-29) Deploy avoids pods: null, clusters: null,
> hosts:
> > > null
> > > 2012-07-11 11:12:41,940 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) DeploymentPlanner allocation algorithm:
> random
> > > 2012-07-11 11:12:41,940 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Trying to allocate a host and storage pools
> > > from
> > > dc:1, pod:null,cluster:null, requested cpu: 500, requested ram:
> > > 536870912
> > > 2012-07-11 11:12:41,940 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Is ROOT volume READY (pool already
> allocated)?:
> > > No
> > > 2012-07-11 11:12:41,940 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Searching all possible resources under this
> > > Zone: 1
> > > 2012-07-11 11:12:41,942 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Listing clusters in order of aggregate
> capacity,
> > > that have (atleast one host with) enough CPU and RAM capacity under
> > > this
> > > Zone: 1
> > > 2012-07-11 11:12:41,943 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) CPUOverprovisioningFactor considered: 1.0
> > > 2012-07-11 11:12:41,953 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Checking resources in Cluster: 3 under Pod:
> 1
> > > 2012-07-11 11:12:41,953 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Calling HostAllocators to find suitable
> hosts
> > > 2012-07-11 11:12:41,953 DEBUG [allocator.impl.FirstFitAllocator]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Looking for hosts
> in
> > > dc: 1
> > >  pod:1  cluster:3
> > > 2012-07-11 11:12:41,954 DEBUG [allocator.impl.FirstFitAllocator]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) FirstFitAllocator
> has
> > > 1
> > > hosts to check for allocation: [Host[-5-Routing]]
> > > 2012-07-11 11:12:41,956 DEBUG [allocator.impl.FirstFitAllocator]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Found 1 hosts for
> > > allocation after prioritization: [Host[-5-Routing]]
> > > 2012-07-11 11:12:41,956 DEBUG [allocator.impl.FirstFitAllocator]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Looking for
> > > speed=500Mhz,
> > > Ram=512
> > > 2012-07-11 11:12:41,957 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Checking if host:
> 5
> > > has
> > > enough capacity for requested CPU: 500 and requested RAM:
> 536870912 ,
> > > cpuOverprovisioningFactor: 1.0
> > > 2012-07-11 11:12:41,960 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Hosts's actual
> total
> > > CPU:
> > > 3590 and CPU after applying overprovisioning: 3590
> > > 2012-07-11 11:12:41,960 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Free CPU: 3590 ,
> > > Requested
> > > CPU: 500
> > > 2012-07-11 11:12:41,960 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Free RAM:
> 4151566336 ,
> > > Requested RAM: 536870912
> > > 2012-07-11 11:12:41,960 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Host has enough
> CPU
> > > and
> > > RAM available
> > > 2012-07-11 11:12:41,960 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) STATS: Can alloc
> CPU
> > > from
> > > host: 5, used: 0, reserved: 0, actual total: 3590, total with
> > > overprovisioning: 3590; requested
> cpu:500,alloc_from_last_host?:false
> > > ,considerReservedCapacity?: true
> > > 2012-07-11 11:12:41,960 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) STATS: Can alloc
> MEM
> > > from
> > > host: 5, used: 0, reserved: 0, total: 4151566336; requested mem:
> > > 536870912,alloc_from_last_host?:false ,considerReservedCapacity?:
> true
> > > 2012-07-11 11:12:41,960 DEBUG [allocator.impl.FirstFitAllocator]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Found a suitable
> host,
> > > adding to list: 5
> > > 2012-07-11 11:12:41,960 DEBUG [allocator.impl.FirstFitAllocator]
> > > (Job-Executor-5:job-29 FirstFitRoutingAllocator) Host Allocator
> > > returning 1
> > > suitable hosts
> > > 2012-07-11 11:12:41,961 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Checking suitable pools for volume (Id,
> Type):
> > > (7,ROOT)
> > > 2012-07-11 11:12:41,961 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) We need to allocate new storagepool for
> this
> > > volume
> > > 2012-07-11 11:12:41,961 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Calling StoragePoolAllocators to find
> suitable
> > > pools
> > > 2012-07-11 11:12:41,963 DEBUG
> > > [storage.allocator.FirstFitStoragePoolAllocator] (Job-Executor-
> 5:job-29)
> > > Looking for pools in dc: 1  pod:1  cluster:3
> > > 2012-07-11 11:12:41,963 DEBUG
> > > [storage.allocator.FirstFitStoragePoolAllocator] (Job-Executor-
> 5:job-29)
> > > No
> > > storage pools available for allocation, returning
> > > 2012-07-11 11:12:41,964 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) No suitable pools found for volume:
> > > Vol[7|vm=7|ROOT] under cluster: 3
> > > 2012-07-11 11:12:41,964 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) No suitable pools found
> > > 2012-07-11 11:12:41,964 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) No suitable storagePools found under this
> > > Cluster: 3
> > > 2012-07-11 11:12:41,964 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Cluster: 1 has HyperVisorType that does not
> > > match
> > > the VM, skipping this cluster
> > > 2012-07-11 11:12:41,964 DEBUG [cloud.deploy.FirstFitPlanner]
> > > (Job-Executor-5:job-29) Could not find suitable Deployment
> Destination
> > > for
> > > this VM under any clusters, returning.
> > > 2012-07-11 11:12:42,271 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29) VM state transitted from :Starting to
> Stopped
> > > with
> > > event: OperationFailedvm's original host id: null new host id: null
> > > host id
> > > before state transition: null
> > > 2012-07-11 11:12:42,481 DEBUG [cloud.capacity.CapacityManagerImpl]
> > > (Job-Executor-5:job-29) VM state transitted from :Stopped to Error
> with
> > > event: OperationFailedToErrorvm's original host id: null new host
> id:
> > > null
> > > host id before state transition: null
> > > 2012-07-11 11:12:43,225 INFO  [api.commands.DeployVMCmd]
> > > (Job-Executor-5:job-29)
> > > com.cloud.exception.InsufficientServerCapacityException: Unable to
> > > create a
> > > deployment for VM[User|i-2-7-VM]Scope=interface
> com.cloud.dc.DataCenter;
> > > id=1
> > > 2012-07-11 11:12:43,225 WARN  [cloud.api.ApiDispatcher]
> > > (Job-Executor-5:job-29) class com.cloud.api.ServerApiException :
> Unable
> > > to
> > > create a deployment for VM[User|i-2-7-VM]
> > > 2012-07-11 11:12:43,225 DEBUG [cloud.async.AsyncJobManagerImpl]
> > > (Job-Executor-5:job-29) Complete async job-29, jobStatus: 2,
> resultCode:
> > > 530, result: com.cloud.api.response.ExceptionResponse@5cebe417
> > > 2012-07-11 11:12:46,824 DEBUG [cloud.async.AsyncJobManagerImpl]
> > > (catalina-exec-4:null) Async job-29 completed
> > >
> > >
> > >
> > >
> > >
> > > On 20 July 2012 18:31, Edison Su <Edison.su@citrix.com> wrote:
> > >
> > > > Could you post mgt server log to someplace? Like pastebin.
> > > >
> > > > From: claude bariot [mailto:clobariot@gmail.com]
> > > > Sent: Friday, July 20, 2012 8:35 AM
> > > > To: cloudstack-users@incubator.apache.org
> > > > Subject: Re: Vsphere host into existing XenServer pod
> > > >
> > > > For your information, see the screen shot in attached file. When
> I
> > > tried
> > > > to add a nexw instance :
> > > >
> > > > On 20 July 2012 17:28, claude bariot <clobariot@gmail.com<mailto:
> > > > clobariot@gmail.com>> wrote:
> > > > thanks,
> > > > I saw all vm templates (xen and vsphere) I also added another
> > > templates
> > > > for all host type.
> > > >
> > > > I can add a new instance on xen host correctly... bat unable to
> > > Vcenter
> > > > (vsphere) ...
> > > >
> > > > I thought, system VM should be done on the Vsphere host before to
> > > adding
> > > >  VM instance in vSphere host....
> > > >
> > > > My secondary Vm running fine ... I also see templates about
> Vmware
> > > > (download complete) ...
> > > >
> > > > I don't why unable de add a new instance ...
> > > >
> > > > regards
> > > >
> > > >
> > > > On 20 July 2012 16:12, Edison Su <Edison.su@citrix.com<mailto:
> > > > Edison.su@citrix.com>> wrote:
> > > > If there are system vms already created on xen server cluster,
> then
> > > no
> > > > system vm will be created in VMware cluster.
> > > > Is your secondary storage vm running? Can you see a vmware
> template
> > > when
> > > > you deploy vm? If not, you may need to check your secondary
> storage
> > > vm,
> > > > make sure it can access public network , and can download the
> default
> > > VMware
> > > > Template.
> > > > Sent from my iPhone
> > > >
> > > > On Jul 20, 2012, at 12:39 AM, "claude bariot"
> > > <clobariot@gmail.com<mailto:
> > > > clobariot@gmail.com>> wrote:
> > > >
> > > > > How can I do it ?
> > > > >
> > > > > Let me know if the following procedure are true :
> > > > > - First, a datastore has been created from VCenter
> (vsphredatastore)
> > > > > - Then, from the CS GUI, I was add a new primary storage
> > > > >
> > > > > *Result *: *NOK*, unable to saw any System VMs on Vsphere
> > > environnement
> > > > and
> > > > > unable to add a new instance because, no System VMs before.
> > > > >
> > > > > Regards
> > > > >
> > > > >
> > > > >
> > > > > On 19 July 2012 20:23, Edison Su <Edison.su@citrix.com<mailto:
> > > > Edison.su@citrix.com>> wrote:
> > > > >
> > > > >> Did you add primary storage for Vsphere cluster?
> > > > >>
> > > > >>> -----Original Message-----
> > > > >>> From: Misoko Kalenda [mailto:kmisoko@genyinfos.com<mailto:
> > > > kmisoko@genyinfos.com>]
> > > > >>> Sent: Thursday, July 19, 2012 3:49 AM
> > > > >>> To: cloudstack-users@incubator.apache.org<mailto:
> > > > cloudstack-users@incubator.apache.org>
> > > > >>> Subject: Vsphere host into existing XenServer pod
> > > > >>>
> > > > >>> Hi all,
> > > > >>>
> > > > >>> I have a pod with 1 xen cluster;
> > > > >>> I was added on this pod, 1 Vsphere cluster ==> success
> > > > >>>
> > > > >>> problems :
> > > > >>>
> > > > >>> - I sow all System VMs on XenServer cluster only bat
> unavailable
> > > on the
> > > > >>> Vsphere cluster.
> > > > >>> - Unable to add instance on the Vsphere cluster
> > > > >>> - When I tried to create a new pod and I inclued a vsphere
> > > cluster, I
> > > > >>> have the same result (NOK to add new instance)..
> > > > >>>
> > > > >>> Question :
> > > > >>> - Where is the best way, for configure CS if you want add
> > > instances in
> > > > >>> the Vsphere and xen hosts  togethere on the same zone ?
> > > > >>>
> > > > >>> Regards
> > > > >>
> > > > >>
> > > >
> > > >
> > > >
> >

Mime
View raw message