cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evan Miller <Evan.Mil...@citrix.com>
Subject What are the API steps to setup a "suitable (storage) pool" correctly for a second, username-specific cluster?
Date Sat, 28 Jul 2012 03:08:53 GMT
Running CloudStack Management Server:
  v3.0.2.1
On:
  [root@cumulus management]# uname -a
  Linux cumulus.eng.citrite.net 2.6.32-220.el6.x86_64 #1 SMP Tue Dec 6 19:48:22 GMT 2011 x86_64
x86_64 x86_64 GNU/Linux
  [root@cumulus management]#
Hypervisor :
  XenServer v6.02

Hi:

I am trying to use the API commands to do the following:

  Add a second cluster specific for a particular username (works),
  Add a host to that second cluster (works), and then
  Add a VM specific to that host as well as specific to the
   account associated with the particular username (doesn't work).

All of those API steps work fine for the first cluster that is created by
Basic Network Setup. However, something is missing above
for the second (username/account specific) cluster/host. The error
I get from the management log is:

2012-07-27 18:52:38,069 DEBUG [storage.allocator.FirstFitStoragePoolAllocator] (Job-Executor-11:job-24)
No storage pools available for allocation, returning
No suitable pools found for volume: Vol[14|vm=11|ROOT] under cluster: 3
2012-07-27 18:52:38,069 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-11:job-24) No suitable
pools found
2012-07-27 18:52:38,069 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-11:job-24) Cannnot
deploy to specified host, returning.

What API steps must I do to get this second cluster/host to spawn
a VM just like the original, first cluster does.

I'm not too familiar with storage pools ...


Regards,

Evan Miller

Citrix Systems. Inc.
Desktop and Cloud Engineering Infrastructure
4988 Great America Parkway
Santa Clara, CA 95054


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message