cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evan Miller <Evan.Mil...@citrix.com>
Subject RE: Cannot add vm to any host in any cluster - error: "Unable to apply dhcp entry on router" - still completely blocked
Date Wed, 25 Jul 2012 23:45:14 GMT
Abhinandan:

I don't understand which ip and which host you are talking about
in your comment:

To check try logging into RVM using ssh keys from the host on which it resides (ssh -p 3922
-I /root/.ssh/id_rsa.cloud  <rvm link local ip>).

At any rate, I tried this from the XenServer that is unable to add the VM:

[root@xenserver1-cs .ssh]# ssh -p 3922 -I /root/.ssh/id_rsa.cloud 169.254.0.227
no support for smartcards.
The authenticity of host '169.254.0.227 (169.254.0.227)' can't be established.
RSA key fingerprint is 58:de:8b:d7:2b:8e:01:2e:cd:f4:58:86:27:e4:94:39.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '169.254.0.227' (RSA) to the list of known hosts.
Permission denied (publickey).
[root@xenserver1-cs .ssh]#

I assumed the RVM's ip address is the Link Local Address (169.254.0.227)?
If not correct, please advise.

What next?

Note:
Before trying the above, I uninstalled CSMS 3.0.2.1 and (part of?) the database
using install.sh. Then, I re-ran the Basic Network Setup from the GUI. The above 
DHCP problem still persists.

Please help. I am still completely blocked.

Evan

-----Original Message-----
From: Abhinandan Prateek [mailto:Abhinandan.Prateek@citrix.com] 
Sent: Monday, July 23, 2012 9:11 PM
To: cloudstack-users@incubator.apache.org
Subject: RE: Cannot add vm to any host in any cluster - error: "Unable to apply dhcp entry
on router"

Another issue can be that the ssh keys are not programmed correctly either on the host or
the routerVm, due to which the dhcp script fails.
To check try logging into RVM using ssh keys from the host on which it resides (ssh -p 3922
-I /root/.ssh/id_rsa.cloud  <rvm link local ip>). If this fails, check the configuration
table for ssh.publickey and ssh.privatekey.

-abhi

>-----Original Message-----
>From: Evan Miller [mailto:Evan.Miller@citrix.com]
>Sent: Tuesday, July 24, 2012 8:29 AM
>To: cloudstack-users@incubator.apache.org
>Subject: RE: Cannot add vm to any host in any cluster - error: "Unable 
>to apply dhcp entry on router"
>
>Can someone please answer follow-up questions from early this morning?
>
>My CSMS Server is not adding any VMs.
>I am *completely* blocked by:
>
>Unable to apply dhcp entry on router
>
>
>Regards,
>Evan
>
>-----Original Message-----
>From: Evan Miller [mailto:Evan.Miller@citrix.com]
>Sent: Monday, July 23, 2012 5:48 AM
>To: cloudstack-users@incubator.apache.org
>Subject: RE: Cannot add vm to any host in any cluster - error: "Unable 
>to apply dhcp entry on router"
>
>How to do all of those router changes from the GUI?
>If not from the GUI, which API commands should be executed?
>More details would be helpful.
>
>Regards,
>Evan
>
>
>
>-----Original Message-----
>From: Rajesh Battala [mailto:rajesh.battala@citrix.com]
>Sent: Sunday, July 22, 2012 7:06 PM
>To: cloudstack-users@incubator.apache.org
>Subject: RE: Cannot add vm to any host in any cluster - error: "Unable 
>to apply dhcp entry on router"
>
>Evan,
>Did you check the status of the VR?. Is DHCP service is running in the VR?
>Please check those services.
>Sometimes I had observed DHCP service will fail to start on a particular eth.
>Quick workaround is restart VR , check the DHCP service and then try to 
>create the instances.
>
>Thanks
>Rajesh Battala
>
>From: Evan Miller [mailto:Evan.Miller@citrix.com]
>Sent: Sunday, July 22, 2012 12:51 AM
>To: cloudstack-users@incubator.apache.org
>Subject: Cannot add vm to any host in any cluster - error: "Unable to 
>apply dhcp entry on router"
>
>Running CloudStack Management Server:
>  v3.0.2.1
>On:
>  [root@cumulus management]# uname -a
>  Linux cumulus.eng.citrite.net 2.6.32-220.el6.x86_64 #1 SMP Tue Dec 6
>19:48:22 GMT 2011 x86_64 x86_64 x86_64 GNU/Linux
>  [root@cumulus management]#
>Hypervisor :
>  XenServer v6.02
>
>Hi:
>
>I can't add any VMs to any hosts in my 3 cluster, two host cloud.
>
>In one attempt, the GUI basically says:
>
>   Unable to create a deployment for VM[User|i-2-7-VM]
>
>Here is small part of the attached management log snippet.
>
>2012-07-21 10:49:25,568 DEBUG [agent.manager.AgentAttache] 
>(DirectAgent-
>62:null) Seq 1-564527128: No more commands found
>2012-07-21 10:49:25,568 INFO  [cloud.vm.VirtualMachineManagerImpl] 
>(Job-
>Executor-1:job-11) Unable to contact resource.
>com.cloud.exception.ResourceUnavailableException: Resource [Pod:1] is
>unreachable: Unable to apply dhcp entry on router
>        at
>com.cloud.network.router.VirtualNetworkApplianceManagerImpl.applyRules
>(VirtualNetworkApplianceManagerImpl.java:2802)
>        at
>com.cloud.network.router.VirtualNetworkApplianceManagerImpl.applyDhcp
>Entry(VirtualNetworkApplianceManagerImpl.java:2089)
>        at
>com.cloud.network.element.VirtualRouterElement.addDhcpEntry(VirtualRout
>erElement.java:738)
>        at
>com.cloud.network.NetworkManagerImpl.prepareElement(NetworkManage
>rImpl.java:1792)
>        at
>com.cloud.network.NetworkManagerImpl.prepare(NetworkManagerImpl.jav
>a:1887)
>        at
>com.cloud.vm.VirtualMachineManagerImpl.advanceStart(VirtualMachineMan
>agerImpl.java:741)
>        at
>com.cloud.vm.VirtualMachineManagerImpl.start(VirtualMachineManagerImp
>l.java:461)
>        at
>com.cloud.vm.UserVmManagerImpl.startVirtualMachine(UserVmManagerIm
>pl.java:2580)
>        at
>com.cloud.vm.UserVmManagerImpl.startVirtualMachine(UserVmManagerIm
>pl.java:2517)
>        at
>com.cloud.event.ActionEventCallback.intercept(ActionEventCallback.java:32)
>        at
>com.cloud.api.commands.DeployVMCmd.execute(DeployVMCmd.java:317)
>        at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:132)
>        at
>com.cloud.async.AsyncJobManagerImpl$1.run(AsyncJobManagerImpl.java:42
>7)
>        at
>java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
>        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
>        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
>        at
>java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.ja
>va
>:1110)
>        at
>java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.j
>av
>a:603)
>        at java.lang.Thread.run(Thread.java:679)
>
>How should this be fixed?
>Can the problem be fixed from the GUI?
>Please advise.
>
>Regards,
>
>Evan Miller
>
>Citrix Systems. Inc.
>Desktop and Cloud Engineering Infrastructure
>4988 Great America Parkway
>Santa Clara, CA 95054


Mime
View raw message