cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sailaja Mada <sailaja.m...@citrix.com>
Subject RE: Removing a Zone
Date Wed, 04 Jul 2012 04:48:59 GMT
Hi,

Can you check the records of vm_instance table with query :>  select id,name,instance_name,private_ip_address,pod_id
from cloud.vm_instance;

This table gives the information about private_ip_address usage within the POD . POD deletion
will fail If there are any system VM entries with the state of expunging . 

Thanks and Regards,
Sailaja.M

-----Original Message-----
From: Caleb Call [mailto:calebcall@me.com] 
Sent: Wednesday, July 04, 2012 9:17 AM
To: cloudstack-users@incubator.apache.org
Subject: Re: Removing a Zone


On Jul 3, 2012, at 3:20 PM, Caleb Call wrote:

> 
> On Jul 3, 2012, at 3:10 PM, Ahmad Emneina wrote:
> 
>> On 7/3/12 1:50 PM, "Caleb Call" <calebcall@me.com> wrote:
>> 
>>> We're setting up a cloudstack install and one of our guys setup the 
>>> first zone as a basic zone.  We need the vlan support the advanced 
>>> provides so we're trying so remove the basic zone and recreate an advanced one.
>>> However, ever after removing system VMs, we are not able to remove 
>>> the pod.  We get an error that says "There are private IP addresses 
>>> allocated for this pod".  This isn't the case though (atleast not that we can
see).
>>> Is there anyway to see where the IPs are supposedly being used, 
>>> and/or forcibly remove this pod or zone?
>>> 
>>> Thanks,
>>> Caleb
>>> 
>> 
>> What you might want to do is disable the zone and set the various 
>> process intervals for cleanup (found in the global settings section) 
>> to run more often. The params you will want to change are the following:
>> - expunge.interval
>> - expunge.delay
>> - network.gc.interval
>> - network.gc.wait
>> 
>> These will require a service restart. I believe you have vm's that 
>> have yet to be expunged. This will speed up the process.
>> 
>> --
>> Æ
>> 
>> 
>> 
> 
> Excellent, We'll give that a shot and see if that clears them up (I'm 
> assuming it will).  Thanks
> 
> Thanks,
> Caleb
> 


We applied these changes and we still get the same error.  We changed everything down to 1
sec and still no luck.  We tried restarting the service, nothing, we even rebooted the server
with no luck.  The odd thing is the only VMs even built were the system VMs, we haven't even
attempted to build or spin-up any instances ourselves.  Like I said, we're still trying to
get the networking piece configured properly.  Are there any other suggestions on what we
could try?  It wouldn't be a big deal to just rebuild the management server but I'd like to
figure this out for when it's a prod machine and I have something like this crop up.

Thanks,
Caleb



Mime
View raw message