cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Davis <scr...@gmail.com>
Subject Any tips on killing/restarting a super-hung XAPI PID?
Date Mon, 04 Jun 2012 23:55:31 GMT
I know that this is primarily CloudStack but I figured some of you grizzled
vets might know of some pointers for me from running your own CS
deployments with XS/XCP.

One of the cluster nodes (XS 5.6 SP2/not master) became unresponsive to
XAPI calls being sent from the CS management server. In the past, a simple
xe-toolstack-restart would do the trick but the script timed out while
restarting the XAPI daemon.

I found the process and first tried to use a simple kill command but the
process was in a "defunct" state. I tried a kill -9 but no joy.

I then found the xapi.pid and manually deleted it and then tried to run
xe-toolstack-restart. Unfortunately this did not work and ultimately I had
to reboot the cluster node.

So... any other ideas on killing a zombie XAPI process? I've like to avoid
rebooting a host :)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message