cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edison Su <Edison...@citrix.com>
Subject RE: basic config gives "unable to add host" error
Date Thu, 07 Jun 2012 18:31:57 GMT


> -----Original Message-----
> From: sebastien goasguen [mailto:runseb@gmail.com]
> Sent: Thursday, June 07, 2012 8:56 AM
> To: cloudstack-users@incubator.apache.org
> Subject: basic config gives "unable to add host" error
> 
> Hi,
> 
> I am trying to setup a basic zone with CS 3.0.1-1
> I have the mgt server running and I can access the GUI, I am bypassing
> the wizard and going through "infrastructure" to setup the basic zone.
> I have the storage setup via NFS and mounted properly.
> I have the agent setup on a KVM host. iptables disabled for now.
> 
> When I finish the setup of the zone, it tries to add the host and
> fails. the GUI says "Something went wrong, please correct the
> following: Unable to add the host"
> Looking into /var/log/cloud/management/management-server.log there is
> not much info:
> 
> 2012-06-07 11:32:20,413 WARN  [cloud.resource.ResourceManagerImpl]
> (catalina-exec-7:null) Unable to find the server resources at
> http://<ip of agent>
> 
> and before that:
> 
> 2012-06-07 11:27:19,391 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-7:null) cloud-setup-agent  -m <ip of manager> -z 1 -p 1
> -c 1 -g 6330f45e-
> 516e-3295-8cd7-029e41d8cbea -a --pubNic=cloudbr0 --prvNic=cloudbr0
> --guestNic=cloudbr0 output:[OK]
> Restore Network ...           to add your network configuration into
> /etc/sysconfig/network-scripts at first
> Try to restore your system:
> 
> Checking the agent, the cloud-agent service is actually not running.
> The only info in the setup log is that cloudbr0 does not exist.
> 
> Does this mean that we need to create the bridges by hand on the agent
> ? I did not see much info about this. I have a single br0 bridge
> currently.

Can you check /var/log/cloud/setupAgent.log on your kvm host?
Or manually execute " cloud-setup-agent  -m <ip of manager> -z 1 -p 1 -c 1 -g 6330f45e-516e-3295-8cd7-029e41d8cbea
-a --pubNic=cloudbr0 --prvNic=cloudbr0 --guestNic=cloudbr0" on your kvm host? What's the outpout?

Usually, cloud-setup-agent failed, due to hostname is not configured properly. Check "hostname
--fqdn"

> 
> Do we need to edit /etc/cloud/agent/agent.properties by hand before
> adding the host via the GUI ?
> 
> Thanks for the help,
> 
> --
> ---
> Sebastien Goasguen

Mime
View raw message