cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jewel Nuruddin <jewel.nurud...@yahoo.com>
Subject Re: Template create from guest vm and the try to create vm from that template
Date Tue, 05 Jun 2012 03:20:39 GMT
Hi All
 
Here I attached my log (grep job-202) for create vm from template(this template is created
from a running vm).
I could not create vm from a template(this template is created from a vm)
If some one have any idea please help me.
 
Thanks
Jewel

--- On Tue, 6/5/12, Alena Prokharchyk <Alena.Prokharchyk@citrix.com> wrote:


From: Alena Prokharchyk <Alena.Prokharchyk@citrix.com>
Subject: Re: Template create from guest vm and the try to create vm from that template
To: "Jewel Nuruddin" <jewel.nuruddin@yahoo.com>
Date: Tuesday, June 5, 2012, 11:29 AM


On 6/4/12 7:03 PM, "Jewel Nuruddin" <jewel.nuruddin@yahoo.com> wrote:

>Hi Alena,
>Sorry to mail you directly because I could not send attache mail into
>mailing-list,
>Here I attached my full log for your kind review,
>I create a vm from ISO and the vm is running properly, I stop that vm and
>create a template form that VM and try to create another vm from that
>template but could  not.
>Please help me.
>Thanks
>Jewel



Jewel, the log is incomplete, it ends at 11 am timestamp. And you don't
have to send the entire log, just do grep by job-202, and send the output
to me/apache user list. That information should be sufficient enough.

Thank you,
Alena.





>
>--- On Tue, 6/5/12, Alena Prokharchyk <Alena.Prokharchyk@citrix.com>
>wrote:
>
>
>
>From: Alena Prokharchyk <Alena.Prokharchyk@citrix.com>
>Subject: Re: Template create from guest vm and the try to create vm from
>that template
>To: "cloudstack-users@incubator.apache.org"
><cloudstack-users@incubator.apache.org>
>Date: Tuesday, June 5, 2012, 1:42 AM
>
>On 6/4/12 12:39 AM, "Jewel Nuruddin" <jewel.nuruddin@yahoo.com
><http://us.mc450.mail.yahoo.com/mc/compose?to=jewel.nuruddin@yahoo.com>>
>wrote:
>
>>hi all
>> 
>>I Create my guest vm and then create template from that guest vm and then
>>when I try to make another guest vm from that template I get the
>>following error.
>>Dose anyone have any idea what is wrong with me.
>> 
>> 
>>2012-06-04 16:33:06,489 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(catalina-exec-20:null) Allocating entries for VM: VM[User|i-2-56-VM]
>>2012-06-04 16:33:06,492 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(catalina-exec-20:null) Allocating nics for VM[User|i-2-56-VM]
>>2012-06-04 16:33:06,499 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(catalina-exec-20:null) Allocaing disks for VM[User|i-2-56-VM]
>>2012-06-04 16:33:06,507 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(catalina-exec-20:null) Allocation completed for VM: VM[User|i-2-56-VM]
>>2012-06-04 16:33:06,507 DEBUG [cloud.vm.UserVmManagerImpl]
>>(catalina-exec-20:null) Successfully allocated DB entry for
>>VM[User|i-2-56-VM]
>>2012-06-04 16:33:06,648 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(Job-Executor-116:job-202) Successfully transitioned to start state for
>>VM[User|i-2-56-VM] reservation id = 33a9e6c7-4401-482f-bf8d-17609cb59ab5
>>2012-06-04 16:33:06,701 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(Job-Executor-116:job-202) Deployment found  - P0=VM[User|i-2-56-VM],
>>P0=Dest[Zone(Id)-Pod(Id)-Cluster(Id)-Host(Id)-Storage(Volume(Id|Type-->Po
>>o
>>l(Id))] : Dest[Zone(1)-Pod
>>(1)-Cluster(1)-Host(1)-Storage(Volume(77|ROOT-->Pool(200),
>>Volume(78|DATADISK-->Pool(200))]
>>2012-06-04 16:33:19,272 DEBUG [cloud.storage.StorageManagerImpl]
>>(Job-Executor-116:job-202) Checking if we need to prepare 2 volumes for
>>VM[User|i-2-56-VM]
>>2012-06-04 16:36:53,294 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(Job-Executor-116:job-202) Cleaning up resources for the vm
>>VM[User|i-2-56-VM] in Starting state
>>2012-06-04 16:36:53,296 DEBUG [agent.transport.Request]
>>(Job-Executor-116:job-202) Seq 1-1107305129: Sending  { Cmd , MgmtId:
>>264216224466399, via: 1, Ver: v1, Flags: 100111,
>>[{"StopCommand":{"isProxy":false,"vmName":"i-2-56-VM","wait":0
>>}}] }
>>2012-06-04 16:36:53,296 DEBUG [agent.transport.Request]
>>(Job-Executor-116:job-202) Seq 1-1107305129: Executing:  { Cmd , MgmtId:
>>264216224466399, via: 1, Ver: v1, Flags: 100111,
>>[{"StopCommand":{"isProxy":false,"vmName":"i-2-56-VM","wait
>>":0}}] }
>>2012-06-04 16:36:53,453 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>>(Job-Executor-116:job-202) Successfully cleanued up resources for the vm
>>VM[User|i-2-56-VM] in Starting state
>>2012-06-04 16:36:53,770 INFO  [api.commands.DeployVMCmd]
>>(Job-Executor-116:job-202)
>>com.cloud.exception.InsufficientServerCapacityException: Unable to create
>>a deployment for VM[User|i-2-56-VM]Scope=interface
>>com.cloud.dc.DataCenter; id=
>>1
>>2012-06-04 16:36:53,770 WARN  [cloud.api.ApiDispatcher]
>>(Job-Executor-116:job-202) class com.cloud.api.ServerApiException :
>>Unable to create a deployment for VM[User|i-2-56-VM]
>
>
>
>The reason vm failed to start - we couldn't create a deployment for it. It
>means that the system initially lacked storage capacity, cpu/ram capacity;
>or vm simply failed to start on the backend, and we couldn't locate
>another host to start vm on.
>
>The log fragment listed in email doesn't have this info, there is a timing
>gap between 16:33 and 16:36:
>
>2012-06-04 16:33:19,272 DEBUG [cloud.storage.StorageManagerImpl]
>(Job-Executor-116:job-202) Checking if we need to prepare 2 volumes for
>VM[User|i-2-56-VM]
>2012-06-04 16:36:53,294 DEBUG [cloud.vm.VirtualMachineManagerImpl]
>(Job-Executor-116:job-202) Cleaning up resources for the vm
>VM[User|i-2-56-VM] in Starting state
>
>
>Did you remove this part of the log manually? If so, please do grep by
>job-202 to get the info about the deployment failure.
>
>
>-Alena.
>
>
>
>
>
>
>
>
>
>
>



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message