cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepti Dohare <deepti.doh...@citrix.com>
Subject Problem in Uploading templates on Vbox . Error log message : "There is no secondary storage VM for secondary storage host nfs://secondary"
Date Thu, 24 May 2012 19:01:02 GMT
Hi,

I installed the management server on my Oracle VBox and after I have completed with the installation
wizard  ,I am not able to  see the CentOS built-in template listed under the templates tab
on the  dashboard.
Error message: There is no secondary storage VM for secondary storage host nfs://10.102.123.240/cloudstack/deepthi/secondary

I run the script /usr/local/cloud/systemvm/ssvm-check.sh in SSVM to check health

=============================================
Management server is 10.0.3.15. Checking connectivity.
ERROR: Cannot connect to 10.0.3.15 port 8250
2012/05/24 08:59:22 socat[3375] E connecting to AF=2 10.0.3.15:8250: Connection timed out
=============================================

The SSVM was not able to ping my management server.  The ip stored in the configuration table
under cloud database stores  the private ip of VBox and  not the public ip.
So, manually changed the IP (UPDATE configuration SET value='public ip' WHERE name LIKE 'host')
of MS in database configuration table and opened  the port.

./ usr/local/cloud/systemvm/ssvm-check.sh
=============================================
NFS is currently mounted
Mount point is /mnt/SecStorage/7a3ca999-450a-3d33-a287-2aaa4add5ffd
Good: Can write to mount point
Management server is 10.103.2.76. Checking connectivity.
Good: Can connect to management server port 8250
Good: Java process is running
==============================================
It worked.

People who use Vbox can try it out and let me know if it worked for them too in  case they
were also stuck in the same enigma.

Thanks,
Deepti




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message