cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alena Prokharchyk <Alena.Prokharc...@citrix.com>
Subject Re: Error when switching network offerings
Date Wed, 30 May 2012 04:14:23 GMT
The doc is incorrect. I'll make sure its fixed for the next release.

-Alena.

From: James Kahn <jkahn@idea11.com.au<mailto:jkahn@idea11.com.au>>
Reply-To: "'cloudstack-users@incubator. org'" <cloudstack-users@incubator.apache.org<mailto:cloudstack-users@incubator.apache.org>>
To: "'cloudstack-users@incubator. org'" <cloudstack-users@incubator.apache.org<mailto:cloudstack-users@incubator.apache.org>>
Subject: Re: Error when switching network offerings

Wow, that is precisely correct Alena. Thank you! I will test later today
and confirm if that fixes it.

I was misled by the the Admin Guide: "Conserve mode. Indicate whether to
use conserve mode. In this mode, network resources are allocated only when
the first virtual machine starts in the network."

From that description, I assumed conserve mode meant that it would not
boot the router and allocate an IP until the first VM is provisioned
rather than that it would not allow an IP to hold multiple roles. We
definitely want to use conserve mode, so I will change our network
offering.



-----Original Message-----
From: Alena Prokharchyk <Alena.Prokharchyk@citrix.com<mailto:Alena.Prokharchyk@citrix.com>>
Reply-To: "cloudstack-users@incubator.apache.org<mailto:cloudstack-users@incubator.apache.org>"
<cloudstack-users@incubator.apache.org<mailto:cloudstack-users@incubator.apache.org>>
Date: Wednesday, 30 May 2012 2:56 AM
To: "cloudstack-users@incubator.apache.org<mailto:cloudstack-users@incubator.apache.org>"
<cloudstack-users@incubator.apache.org<mailto:cloudstack-users@incubator.apache.org>>
Subject: Re: Error when switching network offerings

On 5/27/12 12:37 AM, "James Kahn" <jkahn@idea11.com.au<mailto:jkahn@idea11.com.au>>
wrote:

I'm trying to switch from one network offering to another, and receiving
an error when switching:

"There are multiple services used ip <public IP of Virtual Router>".
(sic)

This occurs when switching any network ­ it's not isolated to one. The
differences between the current network offering and the new network
offering are that there is a higher network rate, and also that redundant
virtual routers are enabled.

This is running CloudStack 3.0.1.

Any clues?

Thanks,
JK.




Looks like these 2 offerings have different values for conserveMode. The
original offering has conserveMode = true, which means that single public
IP can be used for multiple services at the same time (PF/LB/StaticNat).
The offering you are trying to upgrade to has conserveMode=false - the Ips
can't be used for more than one service at a time. The fact your original
network has public Ips used by multiple services makes upgrade to the
offering with conserveMode=false impossible.

Please confirm that this is your case.


-Alena.




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message