cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wwei@landhightech.com" <W...@landhightech.com>
Subject HyperV 虚拟路由器无法启动
Date Fri, 19 Dec 2014 01:46:18 GMT

大家好,
      我们在配置CloudStack + HyperV的环境中,遇到了虚拟路由器无法启动的问题;

我们现在两个系统虚拟机运行正常,可以使用控制台功能,可以上传模板;控制板各项指标显示正常;
但是当我们创建第一个实例时,虚拟路由器无法正常启动;
1.底层日志报错是:无法连接到虚拟路由器的管理的ip地址;

2具体表现为:在CloudStack上一直未starting ;但是在宿主机上,虚拟路由器已经启动;

我们查看虚拟路由器的网卡信息,有管理的ip,公共网络的ip,有来宾的ip,有本地链路的ip;我们ping
CloudStack管理节点的管理网络ip,无法ping 通;我们ping CloudStack管理节点的公共网络ip可以ping
通;

3.我们查看了CloudStack发送创建虚拟路由的消息日志,发现 其中有一个网卡deviceid
1 没有name标签,我们认为这个缺少的应该是management管理网络标签;

"nics":[{"deviceId":2,"networkRateMbps":200,"defaultNic":true,"uuid":"be7dc9f2-eff8-4a7e-8229-ffb3be8f04af","ip":"192.168.20.153","netmask":"255.255.255.0","gateway":"192.168.20.254","mac":"06:32:ac:00:00:36","dns1":"61.177.7.1","dns2":"192.168.10.3","broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://untagged","isolationUri":"vlan://untagged","isSecurityGroupEnabled":false,"name":"public"},

{"deviceId":0,"networkRateMbps":200,"defaultNic":false,"uuid":"5ab944ad-1728-4bf3-8c29-0b14f0d35a1b","ip":"10.1.1.1","netmask":"255.255.255.0","mac":"02:00:79:bb:00:04","dns1":"61.177.7.1","dns2":"192.168.10.3","broadcastType":"Vlan","type":"Guest","broadcastUri":"vlan://347","isolationUri":"vlan://347","isSecurityGroupEnabled":false,"name":"guest"},

{"deviceId":1,"networkRateMbps":-1,"defaultNic":false,"uuid":"dbc356b5-79ca-4f83-9df9-038f89290c89","ip":"192.168.10.121","netmask":"255.255.255.0","gateway":"192.168.10.254","mac":"02:00:3f:19:00:03","broadcastType":"Native","type":"Control","isSecurityGroupEnabled":false},{"deviceId":3,"networkRateMbps":-1,"defaultNic":false,"ip":"0.0.0.0","netmask":"255.255.255.255","gateway":"192.168.20.254","mac":"02:00:3f:ed:00:0b","dns1":"61.177.7.1","dns2":"192.168.10.3","broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://untagged","isolationUri":"vlan://untagged","isSecurityGroupEnabled":false,"name":"public"},{"deviceId":4,"networkRateMbps":-1,"defaultNic":false,"ip":"0.0.0.0","netmask":"255.255.255.255","gateway":"192.168.20.254","mac":"02:00:33:3e:00:0c","dns1":"61.177.7.1","dns2":"192.168.10.3","broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://untagged","isolationUri":"vlan://untagged","isSecurityGroupEnabled":false,"name":"public"},{"deviceId":5,"networkRateMbps":-1,"defaultNic":false,"ip":"0.0.0.0","netmask":"255.255.255.255","gateway":"192.168.20.254","mac":"02:00:18:45:00:0d","dns1":"61.177.7.1","dns2":"192.168.10.3","broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://untagged","isolationUri":"vlan://untagged","isSecurityGroupEnabled":false,"name":"public"},{"deviceId":6,"networkRateMbps":-1,"defaultNic":false,"ip":"0.0.0.0","netmask":"255.255.255.255","gateway":"192.168.20.254","mac":"02:00:5a:83:00:0e","dns1":"61.177.7.1","dns2":"192.168.10.3","broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://untagged","isolationUri":"vlan://untagged","isSecurityGroupEnabled":false,"name":"public"},{"deviceId":7,"networkRateMbps":-1,"defaultNic":false,"ip":"0.0.0.0","netmask":"255.255.255.255","gateway":"192.168.20.254","mac":"02:00:04:24:00:0f","dns1":"61.177.7.1","dns2":"192.168.10.3","broadcastType":"Vlan","type":"Public","broadcastUri":"vlan://untagged","isolationUri":"vlan://untagged","isSecurityGroupEnabled":false,"name":"public"}]

请求大家帮忙看看是否我们的网络规划和配置有问题,麻烦大家了。

状况描述:
1.我们使用CloudStack 4.4.1 + HyperV ;计算节点使用Hyper-V 2012 R2;

2.我们使用三个网段,192.168.10.*,192.168.20.*,192.168.30.*,分别对应于管理(存储)网络,公共网络,来宾网络;

3.我们在Hyper-V 2012 r2中配置了三个虚拟交换机,名字为management,public,guest
分别对应于管理(存储)网络,公共网络,来宾网络;

4.我们在物理交换机上配置管理(存储)网络端口 为access 模式;公共网络端口为access模式;来宾网络端口为trunk模式。

5.我们在CloudStack配置physical Network 中创建了三个physical Network,physical
Network1:流量标签为management,走管理网络(存储默认);physical Network2:流量标签为public,走公共网络;physical
Network3:流量标签为guest,走来宾网络;

Wwei@landhightech.com
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message