cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darren Tang <darrentang...@gmail.com>
Subject Re: 回复: kvm主机加入cloudstack4.0.2失败
Date Fri, 28 Nov 2014 10:17:52 GMT
楼上兄弟正解。
在你添加的那台kvm主机中执行 :
cloud-setup-agent  -m 10.6.27.103 -z 1 -p 1 -c 1 -g
f20023a3-34a2-3ac5-91bd-f99a046ae76a
-a --pubNic=cloudbr0 --prvNic=cloudbr0 --guestNic=cloudbr0
这个命令,查看到哪一步骤报错。
如果没有报错,那么该主机已经被加入cs。然后删除该主机,重新添加即可。以便重新生成agent配置文件。或手动更新。

在 2014年11月28日 下午2:37,yan_5386@163.com <yan_5386@163.com>写道:

> 你好,把这个命令复制下,放到KVM主机上执行以下
>
>
>
> 一直在路上
>
> 发件人: 谢福平
> 发送时间: 2014-11-28 14:26
> 收件人: users-cn
> 主题: 回复: 回复: kvm主机加入cloudstack4.0.2失败
> 但我的日志中有如下内容,请查邮件最初的管理日志:
> 2014-11-28 13:13:44,931 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-15:null) cloud-setup-agent -m 10.6.27.103 -z 1 -p 1 -c 1 -g
> f20023a3-34a2-3ac5-91bd-f99a046ae76a -a --pubNic=cloudbr0 --prvNic=cloudbr0
> --guestNic=cloudbr0 output:[Failed]
>
> 说明执行这个脚本失败了,然后导致配置信息都没有写到agent.properties中。
> 是这样吗?
>
>
> 如果是这个意思,怎呢看命令cloud-setup-agent会为什么失败,日志中能得到的信息很少啊:
> 2014-11-28 13:13:29,330 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-15:null) Executing cmd: cloud-setup-agent -m 10.6.27.103 -z
> 1 -p 1 -c 1 -g f20023a3-34a2-3ac5-91bd-f99a046ae76a -a --pubNic=cloudbr0
> --prvNic=cloudbr0 --guestNic=cloudbr0
> 2014-11-28 13:13:31,394 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) HostStatsCollector is running...
>
>
> ------------------ 原始邮件 ------------------
>   发件人: "yan_5386@163.com";<yan_5386@163.com>;
> 发送时间: 2014年11月28日(星期五) 下午2:22
> 收件人: "users-cn"<users-cn@cloudstack.apache.org>;
> 主题: 回复: 回复: kvm主机加入cloudstack4.0.2失败
>
>
>
> CS加入主机的时候,执行命令cloud-setup-agent  -m 10.6.27.103 -z 1 -p 1 -c
1 -g
> f20023a3-34a2-3ac5-91bd-f99a046ae76a -a --pubNic=cloudbr0 --prvNic=cloudbr0
> --guestNic=cloudbr0  写入配置文件agent.properties
>
>
> 一直在路上
> 发件人: 谢福平
> 发送时间: 2014-11-28 14:06
> 收件人: users-cn
> 主题: 回复: kvm主机加入cloudstack4.0.2失败
> 你好,谢谢你的答复。
> 我的这个文件agent.properties,确实有问题:
> workers=5
> #host= The IP address of management server
> host=10.6.27.103
> #port = The port management server listening on, default is 8250
> port=8250
> #cluster= The cluster which the agent belongs to
> cluster=default
> #pod= The pod which the agent belongs to
> pod=default
> #zone= The zone which the agent belongs to
> zone=default
> 这里不只需要改host,其它的参数好像也不对,如pod,zone的信息,也没有进来
>
> 请问这个文件是什么时候生成的,为什么我的这个文件不对呢
>
> 正常节点的agent.properties内容:
> guest.network.device=cloudbr2
> workers=5
> private.network.device=cloudbr2
> port=8250
> resource=com.cloud.hypervisor.kvm.resource.LibvirtComputingResource
> pod=1
> zone=1
> guid=2f5167d8-b5ff-3714-8c7e-2e8a4d6d43c2
> public.network.device=cloudbr2
> cluster=1
> local.storage.uuid=fd93ad47-8d6b-4561-a1d9-71a93a0c81c9
> domr.scripts.dir=scripts/network/domr/kvm
> LibvirtComputingResource.id=6
> host=10.6.27.2
>
>
> ------------------ 原始邮件 ------------------
>   发件人: "yan_5386@163.com";<yan_5386@163.com>;
> 发送时间: 2014年11月28日(星期五) 中午1:39
> 收件人: "users-cn"<users-cn@cloudstack.apache.org>;
> 主题: 回复: kvm主机加入cloudstack4.0.2失败
> Connecting to localhost:8250            //kvm主机为什么连接这个本地IP
> /etc/cloudstack/agent/agent.properties 配置文件中的host改为CS 地址,重启agent试一下呢
> yan_5386@163.com
> 发件人: 谢福平
> 发送时间: 2014-11-28 13:24
> 收件人: users-cn
> 主题: kvm主机加入cloudstack4.0.2失败
> 环境信息: kvm主机,CS4.0.2,基本网络模式
> 问题描述:增加主机时,管理节点报错,日志如下。每次加入失败,会将主机的SELINUX配置恢复默认,libvirt服务也会停止。
> 2014-11-28 13:13:26,816 INFO  [cloud.resource.ResourceManagerImpl]
> (catalina-exec-15:null) Trying to add a new host at http://10.6.31.4 in
> data center 1
> 2014-11-28 13:13:27,204 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-15:null) Executing cmd: lsmod|grep kvm
> 2014-11-28 13:13:28,324 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-15:null) lsmod|grep kvm output:kvm_intel              52570
> 0
> kvm                   314739  1 kvm_intel
> 2014-11-28 13:13:29,330 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-15:null) Executing cmd: cloud-setup-agent  -m 10.6.27.103 -z
> 1 -p 1 -c 1 -g f20023a3-34a2-3ac5-91bd-f99a046ae76a -a --pubNic=cloudbr0
> --prvNic=cloudbr0 --guestNic=cloudbr0
> 2014-11-28 13:13:31,394 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) HostStatsCollector is running...
> 2014-11-28 13:13:37,120 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl]
> (consoleproxy-1:null) Skip capacity scan due to there is no Primary Storage
> UPintenance mode
> 2014-11-28 13:13:37,517 DEBUG
> [network.router.VirtualNetworkApplianceManagerImpl]
> (RouterStatusMonitor-1:null) Found 0 routers.
> 2014-11-28 13:13:44,931 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-15:null) cloud-setup-agent  -m 10.6.27.103 -z 1 -p 1 -c 1 -g
> f20023a3-34a2-3ac5-91bd-f99a046ae76a -a --pubNic=cloudbr0 --prvNic=cloudbr0
> --guestNic=cloudbr0 output:[Failed]
> ore Libvirt ...           bvirt
> Try to restore your system:
> Restore SElinux ...
> 2014-11-28 13:14:07,120 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl]
> (consoleproxy-1:null) Skip capacity scan due to there is no Primary Storage
> UPintenance mode
> 2014-11-28 13:14:07,517 DEBUG
> [network.router.VirtualNetworkApplianceManagerImpl]
> (RouterStatusMonitor-1:null) Found 0 routers.
> 2014-11-28 13:14:24,049 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) VmStatsCollector is running...
> 2014-11-28 13:14:24,865 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) StorageCollector is running...
> 2014-11-28 13:14:31,395 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-3:null) HostStatsCollector is running...
> 2014-11-28 13:14:37,120 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl]
> (consoleproxy-1:null) Skip capacity scan due to there is no Primary Storage
> UPintenance mode
> 2014-11-28 13:14:37,517 DEBUG
> [network.router.VirtualNetworkApplianceManagerImpl]
> (RouterStatusMonitor-1:null) Found 0 routers.
>
> 在主机侧,日志一直在打印
> 2014-11-28 13:18:13,560 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> Connecting to localhost:8250
> 2014-11-28 13:18:13,560 ERROR [utils.nio.NioConnection]
> (Agent-Selector:null) Unable to connect to remote
> 2014-11-28 13:18:18,561 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> Connecting to localhost:8250
> 2014-11-28 13:18:18,561 ERROR [utils.nio.NioConnection]
> (Agent-Selector:null) Unable to connect to remote
> 2014-11-28 13:18:23,562 INFO  [utils.nio.NioClient] (Agent-Selector:null)
> Connecting to localhost:8250
> 2014-11-28 13:18:23,563 ERROR [utils.nio.NioConnection]
> (Agent-Selector:null) Unable to connect to remote
>
> 初步分析,是主机的哪些配置文件有问题。但是不知道如何进一步定位,求高手指导。
> 主机目前已经配置的内容:
> 一个网桥:管理,存储,来宾共用
> hostname:已经配置/etc/hosts
> SELINUX=permissive
> 防火墙增加:
> -A INPUT -p tcp -m tcp --dport 22 -j ACCEPT
> -A INPUT -p tcp -m tcp --dport 1798 -j ACCEPT
> -A INPUT -p tcp -m tcp --dport 16509 -j ACCEPT
> -A INPUT -p tcp -m tcp --dport 5900:6100 -j ACCEPT
> -A INPUT -p tcp -m tcp --dport 49152:49216 -j ACCEPT
> 配置文件
> /etc/libvirt/qemu.conf
> /etc/libvirt/libvirtd.conf
> /etc/sysconfig/libvirtd
> 都已经修改过了,确定没有问题
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message