cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guo Star <ghxand...@gmail.com>
Subject Re: 回复: 为什么我的双网卡绑定,总是一个网卡有流量呢。
Date Tue, 07 Oct 2014 16:39:56 GMT
你需要清楚理解mode=0的工作模式,一个连接的建立只能选择一条"通道"。如果你要模拟,最好测试apache
benchmark来测试.

在 2014年10月7日 下午11:37,kenwayliu <kenwayliu@gmail.com>写道:

> 业务压力不够,建议使用多客户端测试
>
>
>
> kenwayliu
>
> 发件人: 虚无缥缈
> 发送时间: 2014-07-21 14:44
> 收件人: users-cn
> 主题: 回复: 为什么我的双网卡绑定,总是一个网卡有流量呢。
> 正文已经贴了交换机配置,Cisco 2960s交换机。
>
>
>
>
> ------------------ 原始邮件 ------------------
> 发件人: "linuxbqj@gmail.com";<linuxbqj@gmail.com>;
> 发送时间: 2014年7月21日(星期一) 中午1:20
> 收件人: "users-cn"<users-cn@cloudstack.apache.org>;
>
> 主题: Re: 为什么我的双网卡绑定,总是一个网卡有流量呢。
>
>
>
> mode=0:平衡负载模式,有自动备援,但需要”Switch”支援及设定。
>
> http://support.huawei.com/ecommunity/bbs/10155553.html
>
> 2014-07-18 13:39 GMT+08:00 虚无缥缈 <83675086@qq.com>:
> > A、B两台设备,都是双网卡绑定,mode=0,交换机上也做了端口组,交换机是cisco
> 2960,A上起了nfs,B上挂载nfs,然后进行dd测试,cacti上看总是一个端口流量,手动down掉一个网卡,另外一个网卡才有流量。
> >
> > A:
> > [root@backup ~]# cat /proc/net/bonding/bond0
> > Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
> >
> >
> > Bonding Mode: load balancing (round-robin)
> > MII Status: up
> > MII Polling Interval (ms): 100
> > Up Delay (ms): 0
> > Down Delay (ms): 0
> >
> >
> > Slave Interface: em1
> > MII Status: up
> > Speed: 1000 Mbps
> > Duplex: full
> > Link Failure Count: 1
> > Permanent HW addr:
> > Slave queue ID: 0
> >
> >
> > Slave Interface: em2
> > MII Status: up
> > Speed: 1000 Mbps
> > Duplex: full
> > Link Failure Count: 0
> > Permanent HW addr:‍
> >
> >
> >
> > B:
> > root@storage-xen bak_201]# cat /proc/net/bonding/bond0
> > Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
> >
> >
> > Bonding Mode: load balancing (round-robin)
> > MII Status: up
> > MII Polling Interval (ms): 100
> > Up Delay (ms): 0
> > Down Delay (ms): 0
> >
> >
> > Slave Interface: em1
> > MII Status: up
> > Speed: 1000 Mbps
> > Duplex: full
> > Link Failure Count: 0
> > Permanent HW addr:
> > Slave queue ID: 0
> >
> >
> > Slave Interface: em2
> > MII Status: up
> > Speed: 1000 Mbps
> > Duplex: full
> > Link Failure Count: 0
> > Permanent HW addr:
> > Slave queue ID: 0‍
> >
> >
> >
> > 交换机:
> > interface Port-channel1
> >  switchport access vlan 150
> >  switchport mode access‍
> >
> >
> >
> > interface GigabitEthernet0/3
> >  switchport access vlan 150
> >  switchport mode access
> >  channel-group 1 mode on
> >  spanning-tree portfast
> > !‍
> >
> > interface GigabitEthernet0/10
> >  switchport access vlan 150
> >  switchport mode access
> >  channel-group 1 mode on
> >  spanning-tree portfast‍
>
>
>
> --
> 白清杰 (Born Bai)
>
> Mail: linuxbqj@gmail.com
>
> 敬畏耶和华是智慧的开端
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message