cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darren Tang <darrentang...@gmail.com>
Subject Re: Re:cloudmonkey执行报错
Date Sun, 15 Jun 2014 14:25:22 GMT
我想说,我有2台rhel 6.3机器,两套cs4.3  在一台里面cloudmonkey
可以用,但是认证失败,在另一台里面cloudmonkey可以用,并且可以通过认证。和奇怪。
4.1版本,只需填写apikey和secrtkey就可以,貌似5.1还需要用户名和密码才能正常用。



2014-06-12 10:33 GMT+08:00 wanghaicheng2004@gmail.com <
wanghaicheng2004@gmail.com>:

> hi,all
>
> 感谢,找到了问题的原因。在CentOS6.4上就没有问题,在CentOS6.3上出现了问题。具体导致错误的原因是6.3系统中的python-setuptool版本过低导致,pip升级该软件即可
>
>
>
>
> wanghaicheng2004@gmail.com
>
> 发件人: QJS
> 发送时间: 2014-06-11 15:14
> 收件人: users-cn
> 主题: Re:cloudmonkey执行报错
> 没用过cloudmonkey,我猜想是python版本的问题
>
>
>
>
> ------------------ Original ------------------
> From:  "wanghaicheng2004@gmail.com";<wanghaicheng2004@gmail.com>;
> Date:  Wed, Jun 11, 2014 03:12 PM
> To:  "users-cn"<users-cn@cloudstack.apache.org>;
>
> Subject:  cloudmonkey执行报错
>
>
>
> hi,all
>
> CS4.3安装在CentOS6.3上,在安装cloudmonkey后运行命令报错:
>
> [root@cs-1 ~]# cloudmonkey
> Traceback (most recent call last):
>   File "/usr/bin/cloudmonkey", line 5, in <module>
>     from pkg_resources import load_entry_point
>   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in
> <module>
>     working_set.require(__requires__)
>   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in
> require
>     needed = self.resolve(parse_requirements(requirements))
>   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in
> resolve
>     raise DistributionNotFound(req)
> pkg_resources.DistributionNotFound: requests
> [root@cs-1 ~]#
>
> 可能是什么原因呢?
>
>
>
> wanghaicheng2004@gmail.com
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message