cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tanthalas <tanthalas...@hotmail.com>
Subject 回复: 回复: 关于单网卡安装cloudstack的求助
Date Tue, 22 Apr 2014 15:00:06 GMT







因为带vlan ID,交换机上没做vlan的允许,基本判定网络是不通的,二级存储是零,说明二级存储虚拟机也没有和管理节点通讯正常。你可以不按照官方文档的方法配置KVM的网桥,社区在去年年底的活动中做过相关的介绍有个简易的安装步骤,你可以在社区网站连接的baidu盘里找到。
另外一种偷懒的方法是:在只使用一块网卡的情况下,不需要配置网桥,agent会自动建一个。就满足最低使用要求了。
刘宇超
 发件人: Adagio 发送时间: 2014-04-22 21:18收件人: users-cn主题: 回复:
关于单网卡安装cloudstack的求助谢谢超哥费心的回复。
 
 
1,配置的是高级网络,
2,交换机上没有这个vlan,只是我自己虚拟出来的,分配的是172.16.1.0/24的内部地址
3,vlan 300的网关就是eth0.300子接口网桥cloudvirbr300的ip地址,这个172.16.1.1的网关不存在交换机上,只是cloudvirbr300网桥的Ip地址及网关。
 
 
另外,管理节点也是存储节点,都装在一台电脑上了。主存储能在控制面板里看到已经添加了,但二级存储始终为零,8250,9090端口也开了。
 
 
也用virsh的attach-interface将cloudvirbr300加到二个虚拟机上了。两个虚拟机里能用console登录,也加了路由,在管理节点上也添加了路由,并开了ipv4转发,就是虚拟机始终ping不通主机,导致二级存储报警,容量始终为零。
 
 
另外,我同事用两个网卡(eth0,eth1,eth0作为外网,eth1作为内网172.16段,就都能正常)没有问题,我只是一块网卡,虚拟了个接口,就死活,过不去了。。。。
 
 
被这个小问题折磨了好几天了,,真心肯求大牛救出泥淖。。
 
 
 
 
 
 
 
 
 
 
 
 
------------------ 原始邮件 ------------------
发件人: "tanthalas";<tanthalas510@hotmail.com>;
发送时间: 2014年4月22日(星期二) 晚上9:01
收件人: "users-cn"<users-cn@cloudstack.apache.org>; 
 
主题: 回复: 关于单网卡安装cloudstack的求助
 
 
 
 
 
 
 
 
 
 
按照官方文档的方式安装会有一点误解,但也不说那个文档配置的不对。你配置的是高级网络还是基本网络?另外,这些vlan有在交换机上配置吗?这个网关是真实存在的吗?
刘宇超 发件人: Adagio 发送时间: 2014-04-22 20:14收件人: users-cn主题:
关于单网卡安装cloudstack的求助目前机器上只有一个网卡,eth0,配置了外网地址10.23.0.18,然后虚拟了一个网桥cloudbr0。同时,在eth0上建立了一个vlan
300,即子接口eth0.300,虚拟了一个网桥cloudvirbr300,并且指定了ip地址172.16.1.1,gw=172.16.1.1,mask=255.255.255.0
在cloudstakc里配置时,公共流量kvm标签设cloudbr0,管理,来宾,存储为cloudvirbr300。系统虚拟机及二级虚拟机都能running,获取的地址172.16.1.10和172.16.1.20。留的网关是172.16.1.1,但从虚拟机里ping不通网关。
 
 
肯请高手指点帮助。万分感谢!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message