cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bo Wang <brito.w...@gmail.com>
Subject Re: 回复: 改了linux CS主机ROOT密码后,平台登陆不了问题
Date Wed, 15 Jan 2014 08:32:57 GMT
看日志信息应该就是密码错了,你不如重置一下admin的密码吧
1.直接改数据库,当用admin/password登陆的时候,对应的数据库user表的admin行的password字段为:5f4dcc3b5aa765d61d8327deb882cf99
2.如果这样不行,可能就是从ui段传来的已经使用MD5方式加密了的密码,和后台原始存储的加密密码不一致了,你可以使用浏览器的firebug来调试一下,看看再cloudstack.js的200行左右能看到对应已经使用MD5加密的了密码,然后把这个密码拷出来,存到数据库里就OK了。




2014/1/14 XuChun Jiang <jxc222@yahoo.com>

> unsubscribe
>
>
>
> 许叁征 <xusz@chinanetcenter.com> 于 2014年1月14日, 星期二, 1:16 下午
写道:
>
>
>
> HI ALL,碰到一个问题,
>
> 改了linux CS主机ROOT密码后,平台登陆不了,日志显示以下,改ROOT密码
,依然登
> 陆不了。应如何解决。
>
>
>
> 2014-01-14 12:53:29,114 DEBUG [cloud.user.AccountManagerImpl]
> (catalina-exec-20:null) Attempting to log in user: admin in domain 1
>
> 2014-01-14 12:53:29,114 DEBUG [server.auth.MD5UserAuthenticator]
> (catalina-exec-20:null) Retrieving user: admin
>
> 2014-01-14 12:53:29,115 DEBUG [server.auth.MD5UserAuthenticator]
> (catalina-exec-20:null) Password does not match
>
> 2014-01-14 12:53:29,116 DEBUG [server.auth.LDAPUserAuthenticator]
> (catalina-exec-20:null) Retrieving user: admin
>
> 2014-01-14 12:53:29,117 DEBUG [server.auth.LDAPUserAuthenticator]
> (catalina-exec-20:null) LDAP authenticator is not configured.
>
> 2014-01-14 12:53:29,117 DEBUG [cloud.user.AccountManagerImpl]
> (catalina-exec-20:null) Unable to authenticate user with username admin in
> domain 1
>
> 2014-01-14 12:53:29,118 DEBUG [cloud.user.AccountManagerImpl]
> (catalina-exec-20:null) User: admin in domain 1 has failed to log in
>
> 2014-01-14 12:53:35,510 DEBUG [cloud.user.AccountManagerImpl]
> (catalina-exec-5:null) Attempting to log in user: admin in domain 1
>
> 2014-01-14 12:53:35,510 DEBUG [server.auth.MD5UserAuthenticator]
> (catalina-exec-5:null) Retrieving user: admin
>
> 2014-01-14 12:53:35,511 DEBUG [server.auth.MD5UserAuthenticator]
> (catalina-exec-5:null) Password does not match
>
> 2014-01-14 12:53:35,511 DEBUG [server.auth.LDAPUserAuthenticator]
> (catalina-exec-5:null) Retrieving user: admin
>
> 2014-01-14 12:53:35,512 DEBUG [server.auth.LDAPUserAuthenticator]
> (catalina-exec-5:null) LDAP authenticator is not configured.
>
> 2014-01-14 12:53:35,512 DEBUG [cloud.user.AccountManagerImpl]
> (catalina-exec-5:null) Unable to authenticate user with username admin in
> domain 1
>
> 2014-01-14 12:53:35,513 DEBUG [cloud.user.AccountManagerImpl]
> (catalina-exec-5:null) User: admin in domain 1 has failed to log in
>
> 2014-01-14 12:53:40,660 DEBUG [agent.manager.DirectAgentAttache]
> (DirectAgent-438:null) Ping from 48
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message