cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ma y <breeze7...@gmail.com>
Subject Re: Cloudstack 4.2添加KVM主机后的ip问题
Date Mon, 18 Nov 2013 08:14:06 GMT
好吧,问题解决了,汇报一下情况

关于这个问题,公司领导让我尝试了更换第一块卡和第四块卡的ip,更换后:
第一块卡是连接存储用的地址,172.16.0.211
第二块卡是桥接卡,跑存储和管理流量    (不动)
第三块卡是桥接卡,跑guest和public流量  (不动)
第四块卡是我自己的管理网络地址,192.168.29.211

这样修改后,重新添加主机,发现这一次CS识别出的机器ip地址是192.168.29.211
并且,创建VM和打开web控制台都没有任何问题
看来,CS在把kvm主机加入系统后,将主机的最后一块网卡地址认为是它的管理用地址,这应该是程序开发者的简单设定,没有考虑可能的复杂情况,不过既然发现了,也就知道如何规避了
汇报完毕,给大家做参考


在 2013年11月15日下午1:41,ma y <breeze7086@gmail.com>写道:

> 我的环境是CS4.2+centos6.4(KVM)+高级网络
> 管理主机ip  192.168.29.210
> KVM host上第一块卡是我自己的管理地址,192.168.29.211
> 第二块卡是桥接卡,跑存储和管理流量
> 第三块卡是桥接卡,跑guest和public流量
> 第四块卡是连接存储用的地址,172.16.0.211
>
> 第一块卡和第四块卡上的ip之间互相是不通的
>
>
> 现在,我在CS中添加主机,使用host的管理地址192.168.29.211,期间一切OK,但是主机显示的ip地址是172.16.0.211。虽然创建VM什么的没有问题,但这导致一个问题,日志中告诉我管理机打开web控制台请求的是172.16.0.211,因为192.168.29段和172.16.0段是不通的,所以控制台打不开。
>
> 于是,我做了另外一个尝试,增加了一个KVM host,ip配置和第一台一样,仅仅改了末位
> 第一块卡,192.168.29.212
> 第二块卡,同第一台host
> 第三块卡,同第一台host
> 第四块卡,172.16.0.212
> 添加这台主机进CS的时候,先shutdown了第四块卡,于是CS中识别出来这台主机的ip就是192.168.29.212,不同于第一台。
>
> 接下来,我测试了创建新机器,没有问题,但是新机器会落到第一台主机上。
> 迁移已有的主机,没有问题(这点我比较奇怪)。迁移过来后,由于第二台主机的ip是192.168.29.212,所以打开web控制台正常。
>
> 最后一个测试,把第一台主机删除,重新添加,添加方式和第二台一样,先shutdown
>  172.16.0段的网卡,添加进去后CS上显示192.168.29.211。
> 这时候,再次创建VM,系统日志会提示无法找到合适的存储池"No suitable
storage pool",所以结果是无法创建VM。
>
>
>
> 我个人的猜想是,cloudstack在添加这两台主机的时候,发现主机上能够连通主存储的ip地址是172.16.0段,所以它把这个地址当做了我的日常管理地址记录在了系统中。但是这个地址很重要,他影响了我使用web控制台。
>
> 当我shutdown掉172.16.0段网卡再添加主机的时候,前期没有任何问题,只是在创建VM的时候,它发现无法找到合适的存储。(实际上,主机上的存储连接没有断开过,因为根本就是两个ip段)所以,它可能使用了192.168.29段的地址去探测存储状态,明显是不通的。
>
> 有哪位朋友碰到过这种情况吗?
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message