cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 王耀锋 <wilc...@hotmail.com>
Subject 无法添加主机?
Date Thu, 10 Oct 2013 05:18:08 GMT
2013-10-10 13:16:00,406 DEBUG [cloud.api.ApiServlet] (catalina-exec-14:null) Invalid paramemter
in URL found. param: hosttags=2013-10-10 13:16:00,407 DEBUG [cloud.api.ApiServlet] (catalina-exec-14:null)
===START===  192.168.0.34 -- GET  command=addHost&zoneid=c66ec503-2447-4832-b53e-7c913a766a2a&podid=8cde5872-407c-49bb-868f-e0a646f620d7&clusterid=3b39a6ce-6c91-4d0f-80c5-dc67e87b5a49&hypervisor=KVM&clustertype=CloudManaged&hosttags=&username=root&url=http%3A%2F%2FPS-15.jovaunn.com&response=json&sessionkey=1dm1h696bAGirkQb%2BE3j5djEnpM%3D&_=13813821611322013-10-10
13:16:00,415 ERROR [cloud.api.ApiDispatcher] (catalina-exec-14:null) Exception while executing
AddHostCmd:com.cloud.utils.exception.CloudRuntimeException: Guid is not updated for cluster
with specified cluster id; need to wait for hosts in this cluster to come up        at com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:536)
       at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:140)        at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
       at com.cloud.api.ApiServer.queueCommand(ApiServer.java:544)        at com.cloud.api.ApiServer.handleRequest(ApiServer.java:423)
       at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:312)        at com.cloud.api.ApiServlet.doGet(ApiServlet.java:64)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
       at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
       at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
       at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)  
     at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)    
   at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:615)        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)        at org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
       at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:744)
       at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2282)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
       at java.lang.Thread.run(Thread.java:679)2013-10-10 13:16:00,417 DEBUG [cloud.api.ApiServlet]
(catalina-exec-14:null) ===END===  192.168.0.34 -- GET  command=addHost&zoneid=c66ec503-2447-4832-b53e-7c913a766a2a&podid=8cde5872-407c-49bb-868f-e0a646f620d7&clusterid=3b39a6ce-6c91-4d0f-80c5-dc67e87b5a49&hypervisor=KVM&clustertype=CloudManaged&hosttags=&username=root&url=http%3A%2F%2FPS-15.jovaunn.com&response=json&sessionkey=1dm1h696bAGirkQb%2BE3j5djEnpM%3D&_=13813821611322013-10-10
13:16:00,481 DEBUG [cloud.cluster.ClusterManagerImpl] (Cluster-Heartbeat-1:null) Detected
management node left, id:1, nodeIP:192.168.2.162013-10-10 13:16:00,481 INFO  [cloud.cluster.ClusterManagerImpl]
(Cluster-Heartbeat-1:null) Trying to connect to 192.168.2.162013-10-10 13:16:00,481 INFO 
[cloud.cluster.ClusterManagerImpl] (Cluster-Heartbeat-1:null) Management node 1 is detected
inactive by timestamp but is pingable2013-10-10 13:16:01,894 DEBUG [agent.manager.AgentManagerImpl]
(AgentManager-Handler-4:null) SeqA 3-7: Processing Seq 3-7:  { Cmd , MgmtId: -1, via: 3, Ver:
v1, Flags: 11, [{"ConsoleProxyLoadReportCommand":{"_proxyVmId":2,"_loadInfo":"{\n  \"connections\":
[]\n}","wait":0}}] }2013-10-10 13:16:01,973 DEBUG [agent.manager.AgentManagerImpl] (AgentManager-Handler-4:null)
SeqA 3-7: Sending Seq 3-7:  { Ans: , MgmtId: 279278805450800, via: 3, Ver: v1, Flags: 100010,
[{"AgentControlAnswer":{"result":true,"wait":0}}] }
在添加主机的时候报这个错误,这怎么解决? 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message