cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "WXR" <474745...@qq.com>
Subject 回复: 回复: 回复:cloudstack-agent安装时自动安装了libvirt,导致原先源码编译的libvirt被覆盖,无法使用
Date Mon, 30 Sep 2013 06:47:49 GMT
一般配置RBD作为cloudstack存储的时候,安装的步骤是什么呢?




------------------ 原始邮件 ------------------
发件人: "Wei ZHOU";<ustcweizhou@gmail.com>;
发送时间: 2013年9月30日(星期一) 下午2:16
收件人: "users-cn"<users-cn@cloudstack.apache.org>; 

主题: Re: 回复: 回复:cloudstack-agent安装时自动安装了libvirt,导致原先源码编译的libvirt被覆盖,无法使用



这是源码安装和yum安装的兼容性问题吧。你要不把源码打个rpm包安装?yum应该就不会再重装了。

在 13-9-30,WXR<474745079@qq.com> 写道:
> 先装libvirt是因为agent在安装的时候要求先配置好RBD,而RBD在配置的时候又要求装好有RBD模块支持的libvirt,kvm等。
> 在配置RBD的时候,要求libvirt带有相关模块,所以必须自己用源码安装。
>
> 目前我这边是先源码安装一次,然后装agent的时候会被覆盖,之后再用源码安装一次。目前看起来可以用,不过好像不是一个好方法。
> 不知道在cloudstack配置RBD作为存储的时候,一般的安装方式是怎样的。
>
>
>
>
> ------------------ 原始邮件 ------------------
> 发件人: "tanthalas";<tanthalas510@hotmail.com>;
> 发送时间: 2013年9月30日(星期一) 上午9:02
> 收件人: "users-cn"<users-cn@cloudstack.apache.org>;
>
> 主题: Re: 回复:cloudstack-agent安装时自动安装了libvirt,导致原先源码编译的libvirt被覆盖,无法使用
>
>
>
>
> 默认,安装agent的时候会通过你配置的源来下载libvirt,我之前有过这样的操作,但没报错,所以应该是你配置的源内包含的libvirt的版本和已经安装的版本不一致造成的。
> 所以我建议是不要在安装agent之前就装libvirt,这样比较省心,如果需要最新的版本,就在配置yum源的时候可以指定好,一次安装就解决。
>
> 刘宇超  Richard Liu
>
>
>
>
> 发件人: WXR
> 发送时间: 2013-09-29  14:18:17
> 收件人: 474745079
> 抄送:
> 主题: 回复:cloudstack-agent安装时自动安装了libvirt,导致原先源码编译的libvirt被覆盖,无法使用
>
> 安装agent时,libvirt处出现以下提示:
> Non-fatal POSTIN scriptlet failure in rpm package
> libvirt-0.10.2-18.el6.x86_64
> warning: /etc/libvirt/libvirtd.conf created as
> /etc/libvirt/libvirtd.conf.rpmnew
> warning: /etc/libvirt/qemu.conf created as /etc/libvirt/qemu.conf.rpmnew
> warning: %post(libvirt-0.10.2-18.el6.x86_64) scriptlet failed, exit status
> 1
> 安装完后启动libvirt时报以下错误:
> # service libvirtd start
> Starting libvirtd daemon: libvirtd: /usr/lib/libvirt.so.0: version
> `LIBVIRT_PRIVATE_0.10.2' not found (required by libvirtd)
> [FAILED]
> ------------------ 原始邮件 ------------------
> 发件人: "474745079";<474745079@qq.com>;
> 发送时间: 2013年9月29日(星期天) 下午2:01
> 收件人: "CloudStack邮件组"<users-cn@cloudstack.apache.org>;
> 主题: cloudstack-agent安装时自动安装了libvirt,导致原先源码编译的libvirt被覆盖,无法使用
> cloudstack版本: 4.1.0
> 在安装agent之前,已经使用源码安装了更高版本的libvirt,安装agent之前确认可以正常使用。
> 但在安装agent之后,似乎agent自己通过yum又将libvirt重装了一遍,导致现在libvirt无法启动。
> 请问怎样保持原先源码安装的libvirt能够不被覆盖呢?
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message