cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "wx_csky" <yuanshuai.deve...@gmail.com>
Subject 答复: cloudstack添加kvm主机失败
Date Wed, 24 Apr 2013 02:24:55 GMT
如果在kvm主机上启动是可以的:
执行了【cloud-setup-agent  -m 192.168.6.37 -z 1 -p 1 -c 2 -g
1ab192de-5e6a-39e7-842a-7e56b9a03646 -a --pubNic=cloudbr0 --prvNic=cloudbr0
--guestNic=cloudbr0】后 就死掉了

[root@node1 ~]# service libvirtd status
libvirtd is stopped
[root@node1 ~]# service libvirtd start
Starting libvirtd daemon:                                  [  OK  ]
[root@node1 ~]# service libvirtd status
libvirtd (pid  3336) is running...
[root@node1 ~]# cloud-setup-agent  -m 192.168.6.37 -z 1 -p 1 -c 2 -g
1ab192de-5e6a-39e7-842a-7e56b9a03646 -a --pubNic=cloudbr0 --prvNic=cloudbr0
--guestNic=cloudbr0
Starting to configure your system:
Configure SElinux ...         [OK]
Configure Network ...         [OK]
Configure Libvirt ...         [Failed]
Configuration failed for service Libvirt
Try to restore your system:
Restore SElinux ...           [OK]
Restore Network ...           [OK]
Restore Libvirt ...           [Failed]
[root@node1 ~]# service libvirtd status
libvirtd is stopped
[root@node1 ~]#


-----邮件原件-----
发件人: 马营 [mailto:breeze7086@gmail.com] 
发送时间: 2013年4月24日 10:16
收件人: users-cn@cloudstack.apache.org
主题: Re: cloudstack添加kvm主机失败

你的libvirtd服务器能正常起来吗


2013/4/24 wx_csky <yuanshuai.develop@gmail.com>

> 大家好,有问题需要大家帮忙看一下
>
>
>
> 我在cs4.0.1中添加KVM主机出错:
>
> 2013-04-24 09:05:39,496 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-3:null) Executing cmd: cloud-setup-agent  -m 192.168.6.37
-z
> 1 -p 1 -c 2 -g 1ab192de-5e6a-39e7-842a-7e56b9a03646 -a --pubNic=cloudbr0
> --prvNic=cloudbr0 --guestNic=cloudbr0
>
> 2013-04-24 09:05:46,201 DEBUG [utils.ssh.SSHCmdHelper]
> (catalina-exec-3:null) cloud-setup-agent  -m 192.168.6.37 -z 1 -p 1 -c 2
-g
> 1ab192de-5e6a-39e7-842a-7e56b9a03646 -a --pubNic=cloudbr0
--prvNic=cloudbr0
> --guestNic=cloudbr0 output:[Failed]
>
>
>
> 配置如下:
>
> 1.cloudstack是基本网络
>
> 2.kvm主机:centos6.4+kvm
>
> 3./etc/libvirt/libvirtd.conf配置:
>
>  listen_tls = 0
>
>  listen_tcp = 1
>
>  tcp_port = 16059
>
>  auth_tcp = "none"
>
>  mdns_adv = 0
>
>
>
> 4. /etc/sysconfig/libvirtd
>
>     LIBVIRTD_ARGS="--listen"
>
> 5.、/etc/cloud/agent/agent.properties
>
>         host=192.168.6.37
>
>
>
> 6.网桥配置
>
> /etc/sysconfig/network-scripts/ifcfg-cloudbr0
>
>         DEVICE=cloudbr0
>
>         TYPE=Bridge
>
>         BOOTPROTO=static
>
>         BROADCAST=192.168.6.255
>
>         IPADDR=192.168.6.240
>
>         NETMASK=255.255.255.0
>
>         NETWORK=192.168.6.0
>
>         GATEWAY=192.168.6.254
>
>         ONBOOT=yes
>
> /etc/sysconfig/network-scripts/ifcfg-eth0
>
>         DEVICE="eth0"
>
>         HWADDR="00:1E:67:3A:B0:4E"
>
>         #NM_CONTROLLED="yes"
>
>         ONBOOT="yes"
>
>         BRIDGE=cloudbr0
>
>
>
> 在KVM主机上执行【cloud-setup-agent  -m 192.168.6.37 -z 1 -p 1 -c 2 -g
> 1ab192de-5e6a-39e7-842a-7e56b9a03646 -a --pubNic=cloudbr0
--prvNic=cloudbr0
> --guestNic=cloudbr0】出现如下错误:
>
>
>
> [root@node1 ~]# cloud-setup-agent  -m 192.168.6.37 -z 1 -p 1 -c 2 -g
> 1ab192de-5e6a-39e7-842a-7e56b9a03646 -a --pubNic=cloudbr0
--prvNic=cloudbr0
> --guestNic=cloudbr0
>
> Starting to configure your system:
>
> Configure SElinux ...         [OK]
>
> Configure Network ...         [OK]
>
> Configure Libvirt ...         [Failed]
>
> Configuration failed for service Libvirt
>
> Try to restore your system:
>
> Restore SElinux ...           [OK]
>
> Restore Network ...           [OK]
>
> Restore Libvirt ...           [Failed]
>
>
>
> 我不清楚问题出在哪里,有了解的麻烦告知一下,谢谢
>
>


Mime
View raw message