cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KuiLIU (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-10362) Inconsistent method names
Date Tue, 13 Nov 2018 08:09:01 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-10362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

KuiLIU resolved CLOUDSTACK-10362.
---------------------------------
    Resolution: Fixed

> Inconsistent method names
> -------------------------
>
>                 Key: CLOUDSTACK-10362
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10362
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: KuiLIU
>            Priority: Major
>
> Some Boolean-return methods are named "getXXX",
> but other Boolean-return methods are named "isXXX", such as the following two methods.
> They will return boolean values, rename them as "isXXX" should be more clear than "getXXX".
> api/src/main/java/org/apache/cloudstack/api/command/admin/vlan/ListVlanIpRangesCmd.java
> {code:java}
>      public Boolean getForVirtualNetwork() {
>          return forVirtualNetwork;
>      }
> {code}
> api/src/main/java/org/apache/cloudstack/api/command/user/address/ListPublicIpAddressesCmd.java
> {code:java}
>     public Boolean isForVirtualNetwork() {
>         return forVirtualNetwork;
>     }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message