cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (CLOUDSTACK-10364) Inconsiste "setXXX" method names.
Date Tue, 01 May 2018 15:18:00 GMT


ASF GitHub Bot commented on CLOUDSTACK-10364:

rhtyd commented on issue #2601: CLOUDSTACK-10364: Change the "setXXX" method names to "getXXX".
   @DaanHoogland you comment about `get` have been addressed, the author has used a `generate`
method name prefix that sounds acceptable (generating a name from params).
   This is a pure method name change, build and Travis have passed. I'll merge this based
on these tests and reviews.

This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
For queries about this service, please contact Infrastructure at:

> Inconsiste "setXXX" method names.
> ---------------------------------
>                 Key: CLOUDSTACK-10364
>                 URL:
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: KuiLIU
>            Priority: Major
> The following two methods are named as "setXXX",
> actually, they are not setter but getter.
> Thus, they should be renamed as "getXXX".
> {code:java}
>  private String setVnetBrName(String pifName, String vnetId) {
>         return "br" + pifName + "-" + vnetId;
>     }
>     private String setVxnetBrName(String pifName, String vnetId) {
>         return "brvx-" + vnetId;
>     }
> {code}

This message was sent by Atlassian JIRA

View raw message