cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-10362) Inconsistent method names
Date Wed, 09 May 2018 16:15:00 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-10362?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16469010#comment-16469010
] 

ASF subversion and git services commented on CLOUDSTACK-10362:
--------------------------------------------------------------

Commit 951f73b10749b1d713ab1d740e6667def4bac212 in cloudstack's branch refs/heads/master from
[~BruceKuiLIU]
[ https://gitbox.apache.org/repos/asf?p=cloudstack.git;h=951f73b ]

CLOUDSTACK-10362: Change the "getXXX" method names to "isXXX" (#2600)

These Boolean-return methods are named "getXXX", but other Boolean-return methods are named
"isXXX", such as the following two methods. They will return boolean values, rename them as
"isXXX" should be more clear than "getXXX".

> Inconsistent method names
> -------------------------
>
>                 Key: CLOUDSTACK-10362
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10362
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: KuiLIU
>            Priority: Major
>
> Some Boolean-return methods are named "getXXX",
> but other Boolean-return methods are named "isXXX", such as the following two methods.
> They will return boolean values, rename them as "isXXX" should be more clear than "getXXX".
> api/src/main/java/org/apache/cloudstack/api/command/admin/vlan/ListVlanIpRangesCmd.java
> {code:java}
>      public Boolean getForVirtualNetwork() {
>          return forVirtualNetwork;
>      }
> {code}
> api/src/main/java/org/apache/cloudstack/api/command/user/address/ListPublicIpAddressesCmd.java
> {code:java}
>     public Boolean isForVirtualNetwork() {
>         return forVirtualNetwork;
>     }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message