cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KuiLIU (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-10365) Inconsistent boolean-related method names
Date Tue, 24 Apr 2018 10:12:00 GMT
KuiLIU created CLOUDSTACK-10365:
-----------------------------------

             Summary: Inconsistent boolean-related method names
                 Key: CLOUDSTACK-10365
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10365
             Project: CloudStack
          Issue Type: Improvement
      Security Level: Public (Anyone can view this level - this is the default.)
            Reporter: KuiLIU


These boolean-return methods are named as "getXXX".
Other boolean-return methods are named as "isXXX".
Considering there methods will return boolean values, it should be more clear to rename them
as "isXXX".

{code:java}
     public boolean getEnableRRS() {
         return enableRRS;
     }

    public boolean getEnableRRS() {
         return enableRRS;
     }

     public boolean getShrinkOk() {
         return shrinkOk;
     }
     
     public boolean getSourceNat() {
         return sourceNat;
     }
     
     public boolean getInternalLb() {
         return internalLb;
     }
     
     public boolean getOfferHA() {
         return offerHA;
     }
     
      public boolean getVolatileVm() {
         return volatileVm;
     }
     
     public boolean getIsUserDefined() {
         return isUserDefined;
     }
     
      public boolean getEnablePassword() {
         return enablePassword;
     }
     
     public boolean getEnableSshKey() {
         return enableSshKey;
     }
     
     public boolean getUuidTranslation() {
         return _doUuidTranslation;
     }
{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message