cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (CLOUDSTACK-10362) Inconsistent method names
Date Thu, 26 Apr 2018 13:22:13 GMT


ASF GitHub Bot commented on CLOUDSTACK-10362:

rafaelweingartner commented on issue #2599: CLOUDSTACK-10362, CLOUDSTACK-10363, CLOUDSTACK-10364,
CLOUDSTACK-10365 Change method names.
   @BruceKuiLiu even though everything seems to be ok here, I actually likes the three separated
PRs. It reduced the scope for reviewers.
   If you are going to proceed only with this one, can you please close the others? The choice
is yours.

This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
For queries about this service, please contact Infrastructure at:

> Inconsistent method names
> -------------------------
>                 Key: CLOUDSTACK-10362
>                 URL:
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: KuiLIU
>            Priority: Major
> Some Boolean-return methods are named "getXXX",
> but other Boolean-return methods are named "isXXX", such as the following two methods.
> They will return boolean values, rename them as "isXXX" should be more clear than "getXXX".
> api/src/main/java/org/apache/cloudstack/api/command/admin/vlan/
> {code:java}
>      public Boolean getForVirtualNetwork() {
>          return forVirtualNetwork;
>      }
> {code}
> api/src/main/java/org/apache/cloudstack/api/command/user/address/
> {code:java}
>     public Boolean isForVirtualNetwork() {
>         return forVirtualNetwork;
>     }
> {code}

This message was sent by Atlassian JIRA

View raw message