cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-10359) Inconsistent method names
Date Mon, 23 Apr 2018 14:55:01 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-10359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16448269#comment-16448269
] 

ASF subversion and git services commented on CLOUDSTACK-10359:
--------------------------------------------------------------

Commit f8b63754655daf378cf4a6cce9a76af9dd31d129 in cloudstack's branch refs/heads/master from
[~BruceKuiLIU]
[ https://gitbox.apache.org/repos/asf?p=cloudstack.git;h=f8b6375 ]

CLOUDSTACK-10359: Change the inconsistent method names. (#2591)

* CLOUDSTACK-10359: Change the inconsistent method names.

The two methods are named "getXXX".
The two method are checking the status of variables.
"getCustomized" is not as intuitive as "isCustomized".
"getIsSystem" is not as intuitive as "isSystem" as well.

* Add the missing changes of all usages of method getIsSystem.


> Inconsistent method names
> -------------------------
>
>                 Key: CLOUDSTACK-10359
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10359
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: KuiLIU
>            Priority: Major
>
> The following two methods are named "getXXX".
> The two method are checking the status of variables.
> "getCustomized" is not as intuitive as "isCustomized".
> "getIsSystem" is not as intuitive as "isSystem" as well.
> {code:java}
>     public boolean getCustomized() {
>         return (cpuNumber == null || memory == null || cpuSpeed == null);
>     }
>    public Boolean getIsSystem() {
>         return isSystem == null ? false : isSystem;
>     }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message