cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-10287) Make el7 rpms to depend on OpenJDK8
Date Mon, 02 Apr 2018 19:21:00 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-10287?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16423014#comment-16423014
] 

ASF GitHub Bot commented on CLOUDSTACK-10287:
---------------------------------------------

rhtyd commented on a change in pull request #2519: CLOUDSTACK-10287 package require open jdk
1.8
URL: https://github.com/apache/cloudstack/pull/2519#discussion_r178625206
 
 

 ##########
 File path: packaging/centos7/cloud.spec
 ##########
 @@ -58,7 +58,7 @@ intelligent IaaS cloud implementation.
 
 %package management
 Summary:   CloudStack management server UI
-Requires: java => 1.8.0
 
 Review comment:
   No, only jre is needed but on centos java-1.8.0-openjdk is the jre pkg and java-1.8.0-openjdk-devel
has the jdk.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Make el7 rpms to depend on OpenJDK8
> -----------------------------------
>
>                 Key: CLOUDSTACK-10287
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10287
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.11.0.0
>            Reporter: Rohit Yadav
>            Priority: Major
>             Fix For: 4.11.1.0
>
>
> CloudStack 4.11 el7 rpmsĀ install OK on RHEL7 without openjdk8 installed, and the management
server fails to run. Make changes to the rpm spec file, to enforce that openjdk8 is installed/required
during package installation.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message