cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig Lawson (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CLOUDSTACK-10291) unable to package 4.11 for cents 7
Date Thu, 15 Feb 2018 10:02:00 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-10291?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16365312#comment-16365312
] 

Craig Lawson edited comment on CLOUDSTACK-10291 at 2/15/18 10:01 AM:
---------------------------------------------------------------------

Thanks [ Rohit Yadav|https://issues.apache.org/jira/secure/ViewProfile.jspa?name=bhaisaab] I'll
try those out, however - I'd still be interested in whats preventing the packaging from working
for me as if we adopt Cloudstack fully we'll no doubt want to contribute from time to time
and part of that process will involve packaging.

Initially testing with shapeblue'a repository and we get complaints about python versions
(we have 2.7 installed, it requires 2.6) we don't get this problem when installing 4.10, I'll
raise that question with shapeblue directly.

Hoping to get feedback here on how to roll with the original sources.


was (Author: web-engineer):
Thanks [ Rohit Yadav|https://issues.apache.org/jira/secure/ViewProfile.jspa?name=bhaisaab] I'll
try those out, however - I'd still be interested in whats preventing the packaging from working
for me as if we adopt Cloudstack fully we'll no doubt want to contribute from time to time
and part of that process will involve packaging.

> unable to package 4.11 for cents 7
> ----------------------------------
>
>                 Key: CLOUDSTACK-10291
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10291
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Install and Setup
>    Affects Versions: 4.11.0.0
>         Environment: centos7
>            Reporter: Craig Lawson
>            Priority: Major
>
> Apologies if I've missed something or this is not the right place, I'm keen to get rocking
with cloudstack and this is preventing me from getting this into production.
> As your site advertises the current LTS release being 4.11 I've been trying to get this
running, I notice there are no community released RPM's and want to mange the installations
via yum.
> I've followed the docs shipped with the source to create the packages and get stuck at
the same point - either by using the released sources, or by checking out the git repository
on the 4.11 branch (version 4.11.0.1-SNAPSHOT.el7).
> After building, I pop to the package directory and set things off but end up with the
following packaging error -
> {noformat}
> [root@XNET packaging]# ./package.sh --p noredist -d centos7
>  --pack:simulator:distribution:release noredist -d centos7 --
> Preparing to package Apache CloudStack 4.11.0.1-SNAPSHOT
> . preparing source tarball
> . executing rpmbuild
> error: Failed build dependencies:
>  maven >= 3.0.0 is needed by cloudstack-4.11.0.1-SNAPSHOT.el7.centos.x86_64
> RPM Build Failed{noformat}
> However - maven version is 3.5 -
> {noformat}
> [root@XNET packaging]# mvn -v
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d; 2017-10-18T08:58:13+01:00)
> Maven home: /usr/local/maven
> Java version: 1.8.0_161, vendor: Oracle Corporation
> Java home: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.161-0.b14.el7_4.x86_64/jre
> Default locale: en_GB, platform encoding: UTF-8
> OS name: "linux", version: "3.10.0-693.11.6.el7.x86_64", arch: "amd64", family: "unix"{noformat}
> Completely stuck here and unable to build the packages - have I missed something, is
it possible to use this version yet? As LTS is ending in a few months on 4.9 and 4.10 is not
listed with LTS support we're keen to get this version running.
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message