cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dag Sonstebo (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-10165) VMware 6.0 hypervisor_capability insert failure
Date Wed, 29 Nov 2017 17:02:00 GMT
Dag Sonstebo created CLOUDSTACK-10165:
-----------------------------------------

             Summary: VMware 6.0 hypervisor_capability insert failure
                 Key: CLOUDSTACK-10165
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10165
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
    Affects Versions: 4.9.0, 4.9.2.0, 4.9.1.0, 4.9.3.0
         Environment: CloudStack 4.9.1 on CentOS6.8.
VMware 5.5 / 6.0
            Reporter: Dag Sonstebo
            Assignee: Rohit Yadav


* The 4.6.1 > 4.7.0 schema upgrade should insert VMware 6.0 into the cloud.hypervisor_capabilities
table (ref https://github.com/apache/cloudstack/blob/master/setup/db/db/schema-461to470.sql#L250
)
* The following insert should be made:
INSERT IGNORE INTO `cloud`.`hypervisor_capabilities` values (25,UUID(),'VMware','6.0',128,0,13,32,1,1);
* The above statement has primary database key id=25 hard coded and therefore fails silently
due to the INSERT IGNORE.
* For reference the conflicting entry is:
Execute:
> SELECT * FROM cloud.hypervisor_capabilities where id=25

| id      | uuid      | hypervisor_type      | hypervisor_version      | max_guests_limit
     | security_group_enabled      | max_data_volumes_limit      | max_hosts_per_cluster 
    | storage_motion_supported      | vm_snapshot_enabled      |
| 25      |           | Ovm3                 | 3.2                     | 25              
     | 0                           | 6                           |                       
    | 0                             | 0                        |
| NULL    | NULL      | NULL                 | NULL                    | NULL            
     | NULL                        | NULL                        | NULL                  
    | NULL                          | NULL                     |
2 rows
* As a result VMware 6.0 is not included in CloudStack 4.9.x.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message