cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nitesh Sarda (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-10120) Allow migration of VM's from ACP UI between the hosts with different versions
Date Wed, 25 Oct 2017 10:09:01 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-10120?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nitesh Sarda updated CLOUDSTACK-10120:
--------------------------------------
    Description: 
*ISSUE*

Currently Cloudstack doesn't allow to migrate the VM's between the hosts with different versions
of Hypervisors from UI, whereas using API it is possible. Hypervisor itself allows migration
of VM's between different versions, like VMware allows migration of VM's from 5.1 ESXi to
5.5 ESXi. Similarly XenServer allows migration from 6.2 to 6.5.

*STEPS TO REPRODUCE*

* Create Cloudstack setup with more than one hosts of different version.
* Try to migrate a VM from lower version host to higher version host.
* On UI, it will not list the hosts with different version. Whereas using API migrateVirtualMachineWithVolume,
VM from lower version of host can be migrated to higher version host.

  was:
*ISSUE*

Currently ACP doesn't allow to migrate the VM's between the hosts with different versions
of Hypervisors from UI, whereas using API it is possible. Hypervisor itself allows migration
of VM's between different versions, like VMware allows migration of VM's from 5.1 ESXi to
5.5 ESXi. Similarly XenServer allows migration from 6.2 to 6.5.

*STEPS TO REPRODUCE*

* Create an ACP setup with more than one hosts of different version.
* Try to migrate a VM from lower version host to higher version host.
* On UI, it will not list the hosts with different version. Whereas using API migrateVirtualMachineWithVolume,
VM from lower version of host can be migrated to higher version host.


> Allow migration of VM's from ACP UI between the hosts with different versions
> -----------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-10120
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10120
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: Nitesh Sarda
>
> *ISSUE*
> Currently Cloudstack doesn't allow to migrate the VM's between the hosts with different
versions of Hypervisors from UI, whereas using API it is possible. Hypervisor itself allows
migration of VM's between different versions, like VMware allows migration of VM's from 5.1
ESXi to 5.5 ESXi. Similarly XenServer allows migration from 6.2 to 6.5.
> *STEPS TO REPRODUCE*
> * Create Cloudstack setup with more than one hosts of different version.
> * Try to migrate a VM from lower version host to higher version host.
> * On UI, it will not list the hosts with different version. Whereas using API migrateVirtualMachineWithVolume,
VM from lower version of host can be migrated to higher version host.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message