cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Will Stevens (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-10010) Some S2S VPN configurations fail to establish a connection
Date Thu, 20 Jul 2017 19:48:00 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-10010?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16095256#comment-16095256
] 

Will Stevens commented on CLOUDSTACK-10010:
-------------------------------------------

Work in progress of a fix for this is here: https://github.com/apache/cloudstack/pull/2190

> Some S2S VPN configurations fail to establish a connection
> ----------------------------------------------------------
>
>                 Key: CLOUDSTACK-10010
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10010
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Virtual Router
>    Affects Versions: 4.10.0.0
>            Reporter: Will Stevens
>
> I am not sure if a regression was introduced with this PR #2062, but we have found issues
with this configuration now that we have it in production.
> The core of this change is to change the S2S VPN config from {{auto=start}} to {{auto=route}}.
Read more about this setting here: https://wiki.strongswan.org/projects/strongswan/wiki/ConnSection
> We found there to be issues when using {{auto=start}} for both sides of the connection
as there was problem negotiating the connection. Instead the {{auto=route}} config will only
establish a connection once there is an attempt to send traffic over the connection. In order
to attempt to open the connection as soon as the VPN connection is configured, a ping to the
other side of the connection has been added to establish the connection.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message