cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Angus (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9849) Cannot migrate VMware VM to host in different cluster
Date Mon, 03 Jul 2017 13:29:00 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9849?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16072440#comment-16072440
] 

Paul Angus commented on CLOUDSTACK-9849:
----------------------------------------

I am seeing this issue in a vSphere 5.5u3 environment.
I've tracked it back to this issue:  https://communities.vmware.com/message/2440670?tstart=0#2440670

Of note is this post in the thread from  MKguy 21-Jan-2015 08:17 (in response to CloudServices)

bq. "{{I contacted VMware support in March 2014 and was told the bug was related to the vCenter
5.1 API (we were running vCenter 5.1 at the time) and that it should be fixed with a vCenter
update, however I'm also still getting the same error with vCenter 5.5 U2 and PowerCLI 5.8
R1 2057893.
bq. Note: Using a Datastore object instead of a DatastoreCluster object while keeping -DiskStorageFormat
should also work fine, so I'm working around it by manually selecting the Datastore with the
highest free space from my Datastorecluster like this:
bq. Get-DatastoreCluster MyDatastoreCluster | Get-Datastore | Sort -Property FreeSpaceGB |
Select -Last 1}}"

He notes in a linked thread that thihs is still an issue in the 6.5 API.


> Cannot migrate VMware VM to host in different cluster
> -----------------------------------------------------
>
>                 Key: CLOUDSTACK-9849
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9849
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: VMware
>    Affects Versions: 4.10.0.0
>         Environment: VMware 5.5
>            Reporter: Mike Tutkowski
>            Assignee: Sateesh Chodapuneedi
>             Fix For: 4.10.0.0
>
>
> I have two VMware clusters in the same VMware datacenter. Each cluster has a single ESXi
5.5 host in it.
> I have a shared primary storage in each cluster (I have tried this scenario with both
NFS and iSCSI shared primary storage and the results are the same).
> I have a VM with its root disk running on primary storage from a host in the one cluster
and I cannot migrate this VM and its root disk to the host in the other cluster (both primary
storages even make use of the same storage tag).
> The source host has access to the source datastore, but it does not have access to the
target datastore.
> The target host has access to the target datastore, but it does not have access to the
source datastore.
> When I try to perform the migration, it fails with the following error message:
> Required property datastore is missing from data object of type VirtualMachineRelocateSpecDiskLocator
> while parsing serialized DataObject of type vim.vm.RelocateSpec.DiskLocator
> at line 1, column 327
> while parsing property "disk" of static type ArrayOfVirtualMachineRelocateSpecDiskLocator
> while parsing serialized DataObject of type vim.vm.RelocateSpec
> at line 1, column 187
> while parsing call information for method RelocateVM_Task
> at line 1, column 110
> while parsing SOAP body
> at line 1, column 102
> while parsing SOAP envelope
> at line 1, column 38
> while parsing HTTP request for method relocate
> on object of type vim.VirtualMachine
> at line 1, column 0
> When I run the test in the debugger and look at the VirtualMachineRelocateSpec instance
passed to VirtualMachineMO.changeDatastore, I see the target datastore is populated, but not
the source datastore:
> http://imgur.com/a/vtKcq datastore-66 is the target datastore
> Based on an e-mail chain on dev@, it sounds like my scenario should work.
> Thanks!



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message