cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-3223) Exception observed while creating CPVM in VMware Setup with DVS
Date Wed, 17 May 2017 05:12:04 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-3223?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16013539#comment-16013539
] 

ASF subversion and git services commented on CLOUDSTACK-3223:
-------------------------------------------------------------

Commit 9bed11d1f1195dd5442241f0698f1ef539fa7de9 in cloudstack's branch refs/heads/4.9 from
[~sateeshc]
[ https://gitbox.apache.org/repos/asf?p=cloudstack.git;h=9bed11d ]

CLOUDSTACK-3223 Exception observed while creating CPVM in VMware Setup with DVS

Issue
=====
Exception observed while creating CPVM in VMware Setup with DVS.
Observed error "StartCommand failed due to Exception: com.vmware.vim25.AlreadyExists."
This is due to concurrent attempts to create same dv portgroup on same dvSwitch by
manager threads of CPVM and SSVM when both are started at same time.

Fix
===
Synchronize api calls to create/update dvportgroup.
Also maintaing local cache to avoid multiple fetch api calls to vCenter
when multiple threads try to create same object.

Signed-off-by: Sateesh Chodapuneedi <sateesh.chodapuneedi@accelerite.com>


> Exception observed while creating CPVM in VMware Setup with DVS
> ---------------------------------------------------------------
>
>                 Key: CLOUDSTACK-3223
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-3223
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Install and Setup
>    Affects Versions: 4.2.0
>            Reporter: Kiran Koneti
>            Assignee: Sateesh Chodapuneedi
>             Fix For: 4.9.2.0
>
>         Attachments: IssuewithPublicportgroupupdate.png, management-server.log.2013-06-26
>
>
> Exception occured while creating the CPVM in the VmWare Setup using *VMware dvSwitches*
using the latest SystemVM template, below are the steps followed.
> 1)Tried to create a VMware Advanced Zone  setup using the latest system VM template.
> 2)while creating the CPVM the below error message is observed:
> 2013-06-26 16:30:57,826 WARN  [vmware.resource.VmwareResource] (DirectAgent-3:10.147.40.18)
StartCommand failed due to Exception: com.vmware.vim25.AlreadyExists
> message: []
> com.vmware.vim25.AlreadyExistsFaultMsg: The specified key, name, or identifier already
exists.
>         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
>         at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
>         at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
>         at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
>         at com.sun.xml.internal.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:130)
>         at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:108)
>         at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:78)
>         at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:107)
>         at $Proxy90.addPortGroup(Unknown Source)
>         at com.cloud.hypervisor.vmware.mo.HostNetworkSystemMO.addPortGroup(HostNetworkSystemMO.java:38)
>         at com.cloud.hypervisor.vmware.mo.HostMO.createPortGroup(HostMO.java:382)
>         at com.cloud.hypervisor.vmware.mo.HypervisorHostHelper.prepareNetwork(HypervisorHostHelper.java:866)
>         at com.cloud.hypervisor.vmware.resource.VmwareResource.prepareNetworkFromNicInfo(VmwareResource.java:2853)
>         at com.cloud.hypervisor.vmware.resource.VmwareResource.execute(VmwareResource.java:2617)
>         at com.cloud.hypervisor.vmware.resource.VmwareResource.executeRequest(VmwareResource.java:474)
>         at com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
>         at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
>         at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:166)
>         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
>         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
>         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)"
> 3)The same error message is also observed in the Vcenter also for both 4.1 and 5.0 setups.
> Note:This error message does not prevent the creation of CPVM or any other functionality
of CS,but this would create a panic while creating the setup.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message