cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rajani Karuturi (JIRA)" <>
Subject [jira] [Commented] (CLOUDSTACK-9849) Cannot migrate VMware VM to host in different cluster
Date Wed, 12 Apr 2017 05:33:41 GMT


Rajani Karuturi commented on CLOUDSTACK-9849:

[~sateeshc] any update? were you able to reproduce? 

> Cannot migrate VMware VM to host in different cluster
> -----------------------------------------------------
>                 Key: CLOUDSTACK-9849
>                 URL:
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: VMware
>    Affects Versions:
>         Environment: VMware 5.5
>            Reporter: Mike Tutkowski
>            Assignee: Sateesh Chodapuneedi
>            Priority: Blocker
>             Fix For:
> I have two VMware clusters in the same VMware datacenter. Each cluster has a single ESXi
5.5 host in it.
> I have a shared primary storage in each cluster (I have tried this scenario with both
NFS and iSCSI shared primary storage and the results are the same).
> I have a VM with its root disk running on primary storage from a host in the one cluster
and I cannot migrate this VM and its root disk to the host in the other cluster (both primary
storages even make use of the same storage tag).
> The source host has access to the source datastore, but it does not have access to the
target datastore.
> The target host has access to the target datastore, but it does not have access to the
source datastore.
> When I try to perform the migration, it fails with the following error message:
> Required property datastore is missing from data object of type VirtualMachineRelocateSpecDiskLocator
> while parsing serialized DataObject of type vim.vm.RelocateSpec.DiskLocator
> at line 1, column 327
> while parsing property "disk" of static type ArrayOfVirtualMachineRelocateSpecDiskLocator
> while parsing serialized DataObject of type vim.vm.RelocateSpec
> at line 1, column 187
> while parsing call information for method RelocateVM_Task
> at line 1, column 110
> while parsing SOAP body
> at line 1, column 102
> while parsing SOAP envelope
> at line 1, column 38
> while parsing HTTP request for method relocate
> on object of type vim.VirtualMachine
> at line 1, column 0
> When I run the test in the debugger and look at the VirtualMachineRelocateSpec instance
passed to VirtualMachineMO.changeDatastore, I see the target datastore is populated, but not
the source datastore:
> datastore-66 is the target datastore
> Based on an e-mail chain on dev@, it sounds like my scenario should work.
> Thanks!

This message was sent by Atlassian JIRA

View raw message