cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8284) Primary_storage vlaue is not updating in resource_count table after VM deletion
Date Fri, 17 Feb 2017 08:39:41 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8284?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15871437#comment-15871437
] 

ASF GitHub Bot commented on CLOUDSTACK-8284:
--------------------------------------------

Github user adwaitpatankar commented on the issue:

    https://github.com/apache/cloudstack/pull/1857
  
    @ustcweizhou, the issue is that the resource count at domain level are not getting updated
implicitly after expunge VM call. If the user tries to add a new instance, and if the primary
storage resource count is not up to date, then it results in a false alarm (exception) and
not allowing the user to create a guest instance even though the requested storage space is
withing the limits of the domain quota.
    When we do not pass accountID (as per the fix), the resource counts would be getting calculated
on expungeVM event at Domain level which is the expectation as per the ticket. Also when the
resource calculation is done at Domain level, all resource counts for all accounts within
that domain are recalculated as well.


> Primary_storage vlaue is not updating in resource_count table after VM deletion
> -------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-8284
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8284
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.4.2
>            Reporter: Sonali Jadhav
>            Assignee: adwait patankar
>
> I was doing some tests for checking resource limitation behavior on sub-domain, a/c and
project.
> For account , I didn't set any limits. Instead I set limits on sub-domain. But this specific
Primary storage limit(40GB) acted weird.
> At first in sub-domain, I created new instance (without project), and assigned 41 GB,
and it successfully created VM. Then I deleted that VM with Expunge option enabled, and tried
to create vm again with disk size 42, which failed with error "Maximum number of resources
of type 'primary_storage' for domain id=3 has been exceeded"
> Then I gave disk size to 39GB, that also failed with same error. And now if I create
any disk size its failing. There are no instances or volumes under that sub-domain.
> so which i checked resource_count table, "count" for Primary_storage was not set to zero.
> So then I logged into same domain from UI, and in "Domains" section clicked on "update
resource count". After which in resource_count table "primary_storage" table value went back
to zero.
> For Reference: http://comments.gmane.org/gmane.comp.apache.cloudstack.user/17008 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message