cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9710) Switch to JDK 1.8
Date Mon, 09 Jan 2017 11:19:58 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9710?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15811515#comment-15811515
] 

ASF GitHub Bot commented on CLOUDSTACK-9710:
--------------------------------------------

Github user rhtyd commented on the issue:

    https://github.com/apache/cloudstack/pull/1888
  
    With `cs.jdk.version` set to 1.8 for both as source and target versions, generated jars
can only be run against JRE1.8. Forward compatibility is not supported (build with 1.8, run
on 1.7), we can force the maven compiler plugin to target for 1.7 while set source to 1.8,
but I read that it may not work sometimes and I would like to avoid that given 1.7 has EOL-ed.
    
    Without having package/version dependencies fixated on jdk/jre1.8, sysadmins will only
find out when the agents/usage server or mgmt server fails to start with an error message
such as `Unsupported major.minor version 52.0`


> Switch to JDK 1.8
> -----------------
>
>                 Key: CLOUDSTACK-9710
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9710
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: Rohit Yadav
>            Assignee: Rohit Yadav
>             Fix For: Future, 4.10.0.0
>
>
> Switch to using JDK1.8 by default for building and running CloudStack.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message