cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9676) Start instance fails after reverting to a VM snapshot, when there are child VM snapshots
Date Fri, 23 Dec 2016 12:23:00 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9676?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15772727#comment-15772727
] 

ASF subversion and git services commented on CLOUDSTACK-9676:
-------------------------------------------------------------

Commit b0535d770d108ae219149b5a115c8953d89691d9 in cloudstack's branch refs/heads/4.9 from
[~sateeshc]
[ https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;h=b0535d7 ]

CLOUDSTACK-9676 Start instance fails after reverting to a VM snapshot, when there are child
VM snapshots

Issue
====
Start instance fails after reverting to a VM snapshot, when there is 1 or more child VM snapshots
in the snapshot tree of the VM.
Per the code that detects the presence of a snapshot, we are checking for only current snapshot
instead of checking presence of any snapshot in the snapshot tree.
The failure to detect all snapshots means ACP reconfigures the VM in wrong way assuming there
are no snapshots for the VM.
This results in start failure.

Fix
===
Ensure correct detection of VM snapshots in the VM snapshot tree

This closes #1828

Signed-off-by: Sateesh Chodapuneedi <sateesh.chodapuneedi@accelerite.com>
(cherry picked from commit 673bb25b5936d1c54e9210781280e9ddc507c830)
Signed-off-by: Rohit Yadav <rohit.yadav@shapeblue.com>


> Start instance fails after reverting to a VM snapshot, when there are child VM snapshots
> ----------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-9676
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9676
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: VMware
>    Affects Versions: 4.9.0.1
>         Environment: vSphere 5.5
> ACS master commit 17653a86fad67447a4f13e455e336694ad5c1735
>            Reporter: Sateesh Chodapuneedi
>            Assignee: Sateesh Chodapuneedi
>            Priority: Critical
>             Fix For: 4.10.0.0
>
>
> Start instance fails after reverting to a VM snapshot, when there is 1 or more child
VM snapshots in the snapshot tree of the VM.
> Per the code that detects the presence of a snapshot, we are checking for only current
snapshot instead of checking presence of any snapshot in the snapshot tree. The failure to
detect all snapshots means ACP reconfigures the VM in wrong way assuming there are no snapshots
for the VM. This results in start failure.
> {code:borderStyle=solid}
>      public boolean hasSnapshot() throws Exception {
>          VirtualMachineSnapshotInfo info = getSnapshotInfo();
>          if (info != null) {
>             return info.getCurrentSnapshot() != null;
>          }
>          return false;
>      }
> {code}
> Steps to reproduce
> ===============
> # Prepare setup with esxi5.5
> # Deploy a vm and create three snapshot i1,i2,i3.
> # Delete i2. and stop vm
> # Revert vm to i1
> # Delete i1
> # Start vm
> Start vm is failing with error,
> {noformat}
> StartCommand failed due to Exception: java.lang.RuntimeException Message: Invalid configuration
for device '0'.
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message