cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "subhash yedugundla (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-9557) Deploy from VMsnapshot fails with exception if source template is removed or made private
Date Fri, 21 Oct 2016 12:08:58 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-9557?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

subhash yedugundla updated CLOUDSTACK-9557:
-------------------------------------------
    Description: 
Steps to reproduce the issue
i) Upload a template as admin user and make sure "public" is selected when uploading it.
ii) Now login as a user to CloudStack and deploy a VM with the template created in step i).
iii) Create a VM snapshot as the user for the VM in step ii). Once created deploy a VM from
the snapshot ( this will work as expected)
iv) Now login as admin again , edit the template created in step i) and Uncheck "public".
This is make the template as private ( or else delete the template from UI)
v) Login as same user as in step ii) and try to create a VM from the same snapshot ( created
in step iii)). This will fail now.


  was:
Steps to reproduce the issue
i) Upload a template as admin user and make sure "public" is selected when uploading it.
ii) Now login as a user to CloudPlatform and deploy a VM with the template created in step
i).
iii) Create a VM snapshot as the user for the VM in step ii). Once created deploy a VM from
the snapshot ( this will work as expected)
iv) Now login as admin again , edit the template created in step i) and Uncheck "public".
This is make the template as private ( or else delete the template from UI)
v) Login as same user as in step ii) and try to create a VM from the same snapshot ( created
in step iii)). This will fail now.



> Deploy from VMsnapshot fails with exception if source template is removed or made private
> -----------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-9557
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9557
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Template
>    Affects Versions: 4.8.0
>         Environment: Any Hypervisor
>            Reporter: subhash yedugundla
>             Fix For: 4.8.1
>
>
> Steps to reproduce the issue
> i) Upload a template as admin user and make sure "public" is selected when uploading
it.
> ii) Now login as a user to CloudStack and deploy a VM with the template created in step
i).
> iii) Create a VM snapshot as the user for the VM in step ii). Once created deploy a VM
from the snapshot ( this will work as expected)
> iv) Now login as admin again , edit the template created in step i) and Uncheck "public".
This is make the template as private ( or else delete the template from UI)
> v) Login as same user as in step ii) and try to create a VM from the same snapshot (
created in step iii)). This will fail now.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message