cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9459) Database upgrade from 3.0.7 to 4.9.0 fails with a ResultSet closed exception
Date Mon, 22 Aug 2016 08:51:20 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9459?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15430338#comment-15430338
] 

ASF subversion and git services commented on CLOUDSTACK-9459:
-------------------------------------------------------------

Commit b7f1ba944b4fb6844ac76295a52280539bb038a5 in cloudstack's branch refs/heads/master from
[~rohit.yadav@shapeblue.com]
[ https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;h=b7f1ba9 ]

Merge pull request #1641 from shapeblue/upgrade_fix

CLOUDSTACK-9459: the try's catch block was shortening the preparedstatement's lifethe try's
catch block was shortening the preparedstatement's life resulting in bad resultset when used
outside of try catch.

* pr/1641:
  CLOUDSTACK-9459: the try's catch block was shortening the preparedstatement life resulting
in bad resultset when used outside of try catch.

Signed-off-by: Rohit Yadav <rohit.yadav@shapeblue.com>


> Database upgrade from 3.0.7 to 4.9.0 fails with a ResultSet closed exception
> ----------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-9459
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9459
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Upgrade
>            Reporter: Abhinandan Prateek
>            Assignee: Abhinandan Prateek
>            Priority: Critical
>
> 3735628
> INFO  [o.a.c.s.l.CloudStackExtendedLifeCycle] (main:null) (logid:) Running system integrity
checker com.cloud.upgrade.DatabaseUpgradeChecker@2c79821b
> INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Grabbing lock to check for
database upgrade.
> INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) DB version = 3.0.7 Code Version
= 4.9.0
> INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Database upgrade must be performed
from 3.0.7 to 4.9.0
> ERROR [c.c.u.d.Upgrade410to420] (main:null) (logid:) Unable to discover legacy zones.Operation
not allowed after ResultSet closed
> java.sql.SQLException: Operation not allowed after ResultSet closed
> 	at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:996)
> 	at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:935)
> 	at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:924)
> 	at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:870)
> 	at com.mysql.jdbc.ResultSetImpl.checkClosed(ResultSetImpl.java:734)
> 	at com.mysql.jdbc.ResultSetImpl.next(ResultSetImpl.java:6313)
> 	at org.apache.commons.dbcp.DelegatingResultSet.next(DelegatingResultSet.java:207)
> 	at org.apache.commons.dbcp.DelegatingResultSet.next(DelegatingResultSet.java:207)
> 	at com.cloud.upgrade.dao.Upgrade410to420.persistLegacyZones(Upgrade410to420.java:725)
> 	at com.cloud.upgrade.dao.Upgrade410to420.performDataMigration(Upgrade410to420.java:79)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message