cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9456) Migrate master to use Java8 and Spring4
Date Tue, 16 Aug 2016 21:56:21 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9456?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15423462#comment-15423462
] 

ASF GitHub Bot commented on CLOUDSTACK-9456:
--------------------------------------------

Github user jburwell commented on the issue:

    https://github.com/apache/cloudstack/pull/1638
  
    @rhtyd there is a difference between supporting Java8 and using it as the default version.
 By changing the POMs, Maven will require that Java8 in order to use CloudStack dependencies.
 Furthermore, making Java8 ripples into supported Tomcat versions and Linux distributions.
 Therefore, we agreed sometime ago that 4.x would support Java8, and 5.0.0 would require/default
to it. Personally, I would like to adopt Java8 as soon as possible, but we have to recognize
that many of our users can move so quickly.  I would also like to do it once we have Jetty
embedded so that the upgrade is much simpler for users of Linux distributions because they
will no longer be concerned with version matching Tomcat.


> Migrate master to use Java8 and Spring4
> ---------------------------------------
>
>                 Key: CLOUDSTACK-9456
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9456
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: Rohit Yadav
>            Assignee: Rohit Yadav
>             Fix For: 4.10.0, Future
>
>
> We need to move master to use Java8 and Spring4.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message