cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9456) Migrate master to use Java8 and Spring4
Date Fri, 12 Aug 2016 10:54:20 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9456?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15418668#comment-15418668
] 

ASF GitHub Bot commented on CLOUDSTACK-9456:
--------------------------------------------

GitHub user rhtyd reopened a pull request:

    https://github.com/apache/cloudstack/pull/1638

    CLOUDSTACK-9456: Use Spring 4 and Java 8

    This changes makes CloudStack use spring 4 and Java 8:
    
        - Bumps jdk version to 1.8
        - Use jdk8 for Travis CI
        - Bump spring-framework version to 4.x and Jetty to version that runs with JDK8
        - Bump servet dependency version
        - Migrates various xmls to use version independent schema uris
    
    Outstanding issues:
        - F5 plugin as it fails to build due to issue in axis/library dependency (Stub not
accessible), it is commented/disabled for now
        - A unit test in server that fails which I could not fix so I've disabled it for now:
          com/cloud/vm/DeploymentPlanningManagerImplTest.java
        - Testing of various non-standard plugins such as network and storage plugins etc.
    
    Since, this is a big change pinging for review -- @jburwell @karuturi @wido @murali-reddy
@abhinandanprateek @DaanHoogland @GaborApatiNagy @JayapalUradi @kishankavala @K0zka @nvazquez
@rafaelweingartner @pyr and others
    
    @blueorangutan package

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/shapeblue/cloudstack spring4-java8-only

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/cloudstack/pull/1638.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1638
    
----
commit 8ed1f0187aa92203ae8f58a4cfacec26191b3419
Author: Rohit Yadav <rohit.yadav@shapeblue.com>
Date:   2016-05-13T10:26:48Z

    CLOUDSTACK-9456: Update Spring version in maven poms and use Java 8
    
    - Bumps jdk version to 1.8
    - Use jdk8 for Travis CI
    - Bump spring-framework version to 4.x and Jetty to version that runs with JDK8
    - Bump servet dependency version
    
    Outstanding issues:
    - Disables F5 plugin as it fails to build
    - Disable a unit test in server that fails:
      com/cloud/vm/DeploymentPlanningManagerImplTest.java
    
    Signed-off-by: Rohit Yadav <rohit.yadav@shapeblue.com>

commit 4a0d5c000be8767bf75fb0668df227c3bd92dee3
Author: Rohit Yadav <rohit.yadav@shapeblue.com>
Date:   2016-05-13T10:46:15Z

    CLOUDSTACK-9456: Migrate spring xmls to version 4
    
    Fixes schema locations that are 3.0 dependent in various xmls.
    
    Signed-off-by: Rohit Yadav <rohit.yadav@shapeblue.com>

----


> Migrate master to use Java8 and Spring4
> ---------------------------------------
>
>                 Key: CLOUDSTACK-9456
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9456
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: Rohit Yadav
>            Assignee: Rohit Yadav
>             Fix For: 4.10.0, Future
>
>
> We need to move master to use Java8 and Spring4.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message