cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rajani Karuturi (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-8948) Volume migration not working in asynchronous way
Date Fri, 05 Aug 2016 10:02:20 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-8948?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rajani Karuturi resolved CLOUDSTACK-8948.
-----------------------------------------
    Resolution: Fixed

all the operation on a VM are queued. But, operations on different vms can be parallel. please
test with latest version and reopen if you are still facing this issue.

> Volume migration not working in asynchronous way
> ------------------------------------------------
>
>                 Key: CLOUDSTACK-8948
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8948
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: API, VMware, Volumes
>    Affects Versions: 4.5.2
>         Environment: vSphere 5.5
> CentOS 6.5
> 2 Mangament Servers
> 1 MySQL Server
>            Reporter: Emil
>            Priority: Blocker
>
> We are trying to use the command migrateVolume which is written as asynchronous in cloudstack
API.
> But in some way every time we try to run the command (through the API or Web)
> only 1x migration running at a time (At very very rare situations 2x migrations running
simultaneously).
> I tried to check every configuration settings especially those:
> execute.in.sequence.hypervisor.commands
> execute.in.sequence.network.element.commands
> They were defaulted as false, I tried them with true as value also didnt worked.
> Also if we are trying to run storage vMotion through the vSphere client, it working great
(3,4,5 simultaneously)
> Some logs conclusions:
> 	When preforming the first volumeMigration it seems like each task has a sequence id,
which registerd some where,
> 	then the task "Executing" it self and every thing fine. Got unique job id  for the task
(to trace the status).
> 	When the second volumeMigration executed there is a line in the log which very suspicious
and it says:
> 		"Waiting for Seq 244522346426 Scheduling: .."
> 	That sequence id is the id of the first migration ! Why the hell he waiting for the
first task ?!



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message