cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohammad Aladwan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9405) listDomains API call takes an extremely long time to respond
Date Mon, 06 Jun 2016 14:41:21 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9405?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15316567#comment-15316567
] 

Mohammad Aladwan commented on CLOUDSTACK-9405:
----------------------------------------------

Dear all,

I don't know if this the right place, please if my question in another
section, redirect me.

i have question, whats the way protect ISO image in cloudstack from any
attack.

thanks


> listDomains API call takes an extremely long time to respond
> ------------------------------------------------------------
>
>                 Key: CLOUDSTACK-9405
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9405
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: API
>    Affects Versions: 4.8.0
>            Reporter: dsclose
>              Labels: performance
>
> We recently upgraded from Cloudstack 4.5.2 to Cloudstack 4.8.0. Since this update, the
listDomains API call has started taking an extremely long time to respond. This has caused
issues with our services that rely on this API call. Initially they simply timed out until
we increased the thresholds. Now we have processes that used to take a few seconds taking
many minutes.
> This is so problematic for us that our organisation has put a halt on further updates
of Cloudstack 4.5.2 installations. If reversing the update of zones already on 4.8.0 was feasible,
we would have reverted back to 4.5.2.
> Here is a table of the times we're seeing:
> ||CS Version||Domain Count||API Response Time||
> |4.5.2|251|~3s|
> |4.8.0|182|~26s|
> |4.8.0|<10|<1s|
> This small data sample indicates that the response time for zones with a larger amount
of domains is significantly worse after the update to 4.8.0. Zones with few domains aren't
able to reproduce this issue.
> I recall a bug being resolved recently that concerned reducing the response time for
list* API calls. I also recall [~remibergsma] resolving a bug concerning the sorting of the
listDomains response. Is it possible that these issues are connected?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message