cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8818) Python scripts should depend on mysql.connector instead of MySQLdb
Date Wed, 11 May 2016 03:55:13 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8818?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15279469#comment-15279469
] 

ASF subversion and git services commented on CLOUDSTACK-8818:
-------------------------------------------------------------

Commit d2a95b4c691a844b24616e30a290a9839df643ee in cloudstack's branch refs/heads/master from
[~williamstevens@gmail.com]
[ https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;h=d2a95b4 ]

Merge pull request #1054 from wido/CLOUDSTACK-8818

CLOUDSTACK-8818: Use MySQL native connector with PythonMySQLdb has been deprecated and is
also not supported in Python 3.

mysql.connector is a connector written in Python which talks the
native MySQL protocol without any external code.

https://dev.mysql.com/doc/connector-python/en/

* pr/1054:
  CLOUDSTACK-8818: Use MySQL native connector with Python

Signed-off-by: Will Stevens <williamstevens@gmail.com>


> Python scripts should depend on mysql.connector instead of MySQLdb
> ------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-8818
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8818
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: Wido den Hollander
>              Labels: mysql, python, python3
>
> Our current Python scripts depend on MySQLdb for MySQL connections.
> The best way to go is the native mysql.connector which implements the MySQL protocol
in native Python instead of depending on external libraries.
> It would be best if we drop MySQLdb and use mysql.connector since that also supports
Python 3.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message